352
questions

Fixed alternator in car and warning light is still on. Is the alternator faulty or does warning need reset.

Securing hook on drivers side just catching. Passenger side hook making good contact.

car will not run. the car will run eventually after turning the key a thousand times and it will run fine but after waiting about an hour it will just do the same thing again. we put a new fuel pump, coils, ejectors, spark plugs, and car will still do the same thing!!! what could it be??

car will not run. the car will run eventually after turning the key a thousand times and it will run fine but after waiting about an hour it will just do the same thing again. we put a new fuel pump, coils, ejectors, spark plugs, and car will still do the same thing!!! what could it be??

I have a 1990 mustang gt with a carb swap was bought this way before you say why in the he!! Did you do that.lol I have replaced entire fuel system added a regulator replaced the fender mounted ignition module new distributor replaced intake manifold gaskets and new plugs but I still have a skip please help

When driving sometimes temp gauge goes to cold and warning light comes on. Sometimes will also cause check engine light to come on

1967 Ford Mustang/ 289/C4...when starting the car, the engine misses like crazy, and the worst, over 30MPH the car vibrates/shakes...the entire car...electronic ignition is installed. Car is well maintained. THX.

I would go about 10-30 mph and bogg out and misfire.now I have no power.I changed my spark plugs and wires and made sure they were all right.Does anybody know what is wrong?

I have check fuses and rested my power to the fuel pump connector and I'm getting 9.7v. Test the fuel pressure at the rail and I'm not getting anything. Leads me to believe that it might be the fuel pump but I haven't checked the relay cause I can't find it. I'm assuming it's in the keyless entry stuff....?

engine fan comes on 15 seconds after the car starts and never shuts off while engine is running. Ac quit working

The air switch to change from Vent - Floor - Defrost - AC etc. does not seem to work. I was told it may be the door is broken or the vacuum lines not working. I have replaced the switch but still cannot change the mode.

this problem is intermittent .It seem that the engine used to rev up slightly while letting out clutch or depressing clutch it seems that it has got worse since hot weather has arrived and i'm using a/c.

Hello Car gurus.
I have a Ford Mustang 2005 with 17,000 original miles on it. Last year I noticed that the engine light came on after taking it to get the wheel alignment done. I checked it on one of those hand held OB11 reader unit, and it popped up as P0420 and a pending P0430 code.
Many people I ask are saying it's the CAT that may have gone bad, but is that possible since I barley drive the car? There were some modifications done, including adding in a performance chip, plus changing out the headers, and the air filter.
However, those mods I mentioned were done over 7 years ago, and no issues with check engine lights, or passing the emissions since.
Can someone let me know if it's possible that the CAT could go bad in 10 years at 17,000 miles? Should I just change out the O2 sensors for the bank 1?
The readiness monitors seems to all be showing green, but since it's throwing this code I think it may not pass emissions.

How to proceed....?

Could this be my tire axle? if so whats a good estimate of getting it fixed?

they also changed ccrm programed a new key....nothin now there saying it could b a crank sensor or cam sensor i forget ....what do u think?

cylinder 1 ignition coil shorts out and busts open and starts smoking.. never done this before.. tested input from connector putting out 13.7.. smoked 4 coils in a row... connector and wires do not get hot only coils seam to malfunction, tested several times same results... Any ideas?