Close

Ford F-350 Questions

Get answers to questions about your Ford F-350 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
196
questions

when i came back to calif. i was about 3mi to go then i had engine power loss could not go up the slightest hill only 3 to 10 miles per if i speed up the engine turns off. waited awhile then inched my way to thousand trail. what could be the problem could it be vacuum or electrical could you answer on this page thanks




Truck jut got out of a transmission rebuild and engines was runnin great before and now overheats and won't go over a certain speed and needs high RPMs to change gears.

my truck idles fine but when I go down the road it gets a mis in it I changed the plugs, coil, wires, cap, rotor, cap and plugs and still cant find the problem anyone out their help me out I hope someone has some ideas

Had just put my plow on went bout 30 miles on highway and smoke started to pour out of coolant over flow tank. Stopped and checked it the cover blew off. I made a make shift one and got about another 10 miles and the top radiator hose blew off! Fixed that and got another 10 miles before it was pour smoke everywhere, complete white out. There was no pressure in top or bottom hoses and top was hot bottom was stone Cold. Is this a bad head or could it b something as simple as a thermostat.... Mind u my temp gage doesn't work but truck was fine for the 70mile trip to go get the plow... FYI it's a 89 f350 7.3 diesel turbo! Thanks for ur advice!!!!

using too much oil, not leaks, no smoke, plenty of power

it only sounds when I drive in potholes I have already change both top and bottom ball joints also all tie rod ends and still

misfire and quitting during acceleration when warm

Sometime the engine cranks easily and the next time it will hardly turn over.

I just replaced plugs, wires, cap and roter. I readjusted the wire routing. Still rough running and misfiring

Oil changed less than 4000 miles

running on 7 cyl,s I changed that fuel inj.and is still smoking and running rough.when i unplug that inj.it stops smoking.what could be the problem?

tried fuel line deicer.changed plugs dist. cap and rotor. above 40 it starts ok..at high rpm or full throttle there is backfire and loss of power

how do I find out if fire was caused by recalled part and what steps can I take to get it fixed by them if there is anything that can be done. It was bought from a private party and we've been told that it could've been the speed control switch. Can anyone please point me in the right direction?

oil is blowing out of pipe going into engine

Rust in fuel system.
Will not start.
Changed both fuel filters.

i wont to no if i can put in a c6 instead

If I don't start the truck daily oritsits formore than 10 hrs it won't start. runs smooth as silk when it warms up. no missing is there a check valve that allows air into the fuel lines because it sounds like it is not getting fuel, once it starts it perfectly fine, only does this when it sits.

I haven't driven the truck often. When I parked it, it was fine but water in tank light was on. The filters were changed. The tanks were cleaned out and fuel pumps changed. Batteries (2) are new. Could it be the fuel line or what could be wrong?

with new fuse, what can i check to take care of this problem?

also put on new throtle position sencor new plugs,wires cap rotor.it seemed to start after i put new coil on?

Drove the truck for almost a year with only one battery and no probs.Took a road trip and turned it off after 400miles and it would not start.Cranks, but won't turn over.Bought one new batteriy and it cranked fine but if it sits for a day or 2 the battery is dead.Bought a new 2nd battery today.Cranked right up, drove for 20mins,tried to crank again same thing. Cranks, won't turn over.you can crank it by spraying air cleaner in the air filter.Bought a new air filter today, but it's still doing the same thing.Electrical???

fuse 9 is pcm, pcm power relay, inj pressure reg, inj driver module. with fuse out i can wiggle wires to pcm block and have current.

Fuse was blown, but then, another fuse blew. Where should we have the interior electrical system checked out, in outer SE Portland?

Do you push the rod in or do you have to release pressure

replaced hydro boost and master cylinder , plus all of the brakes , calipers and front hose's/lines.

my truck is running hot at lower rpm. when i accelerate it gets colder and will run on thermostat temp until it shifts to lower rpm. i hear a clincking pulsing noise in top radiator hose almost as if it is a pressure build up of some sort. brand new radiator ruptured but was under warranty so i put new one in. new water pump also.

as i accelerate my temp comes down. running hotter then should but never overheats or boils over. replaced waterpump, radiator, tstat. Can this be a partially plugged cat. check engine light comes on then goes off after about 8 seconds. engine seems to never lack power. still runs but i dont want to damage engine. this is my work truck and need it asap

1990 F-350, bought a box van that had the ignition punched. Have exact column from a Bronco I have but I'm having a problem disconnecting the shift rod from the lever on the column.

I need to see a manual on engine relays and the fusses it cranks but won't start.

The ticking gets faster when I accelerate. But It doesnt do it if it's not in gear.