Ford Escort Questions

All Ford Escort Questions

Ask a Question
none of the lights come on. checked the battery and its good.
check other sources for oil leak they're good, such as oil filter. oil is coming out about a quart within a day or so.
Power steering pulley needs replacing, how much does that normally cost, already have the part
Car starting to shake after you go up to 80 kms. Shaking seems to be coming from under steering wheel. Maybe need a new tire rod????
I'm having problems with my idler pulley bolt breaking I replaced that same bolt 3 times since buying the car in August, I replaced the tensioner and now the check engine light is on.
Short has been a nuisance for some time (in the lights and probably elsewhere). Just recently with the loss of a battery, and a drive home on only alternator power did it start blowing the 10 Amp fuse every time you s...
Shifts fine, and when in gear button works, will not allow gear to change to an unwanted gear. But, when in park button will not disengage and will not allow the key to release from ignition.
Does this for about a minute then blows out regular white exhaust. Been doing it for about a month. Some days on startup it is fine though.
I got new catalytic converter but car still dies at 40mph and engine light flashes so I let off gas n it starts going again. Is it the ccrm? Control relay module? Its prob fuel pump but also ac blows hot air
So far I have checked the voltage at the 02 sensor itself and it is not the same as what the live data view is showing me IE: .3 at the signal voltage and live data view is still showing 0.00. This tells me something...
I have had issues with my alarm on my car and following its repair the radio is asking for a code, who do I get a code from and what details will I need to be able to get the correct code for my car? Thanks, Lizzie
I know where the sensor is, on top of the trans mission! Is there a fuse for it and where is IT ? and if i disconnect the sensor what should the voltage be ?
car died while driving. made rattling sound. checked timing belt which was replaced less than 2 yrs ago. Tried to line up timing marks with socket & breaker bar. Motor would hang up and wouldn't move. Had to move back...
Timing belt less than 2 yrs old. Tried to line up timing marks but motor hangs up near that point. will not move unless I move it back and forth and then it slips by the mark. Don't remember this happening when I repl...
I replaced the fuel pump and still having hard starts fuel pressure drops to zero when pumps off
Already checked all fuses and bulbs they are all good just no brake lights
My brakes have been pulsing while applying them to stop. I have a 1999 Ford Escort.
I took my car to get a serpentine belt changed and get the transmission fluid and filter changed and now it won't move out of the bay at jiffy lube. It turns on and switches gears but won't move forward when you hit t...
car wont start but turns over. done checked fuses and they are good. poured fuel in the carburetor and it started, I think its a fuel problem. fuel pump doesn't come on, but I checked wiring at the plug in and have no...
The car stays crank for maybe two minutes then dies. What is the problem. the alternator was rebuilt and installed but the battery wasn't charged.
The old man just replaced/repaired the transmission and it's working great with the exception of the brakes! The brakes are pulsing while driving and make a hiss-like noise when in park. Also sounds terrible while dri...
When I'm looking at it I see a 1.9 timing belt but when I called Auto Zone they say it comes up on the computer a 2.0 Is it an interference engine or not?
For a few months now my car seems to rev in the RPMs when accelerating and almost gets stuck in the gears (she's an automatic) and when I let off the gas it'll shift and then be fine. After "babying" her for awhile th...