Ford Escort Questions

All Ford Escort Questions

Ask a Question
Timing belt less than 2 yrs old. Tried to line up timing marks but motor hangs up near that point. will not move unless I move it back and forth and then it slips by the mark. Don't remember this happening when I repl...
I replaced the fuel pump and still having hard starts fuel pressure drops to zero when pumps off
Already checked all fuses and bulbs they are all good just no brake lights
My brakes have been pulsing while applying them to stop. I have a 1999 Ford Escort.
I took my car to get a serpentine belt changed and get the transmission fluid and filter changed and now it won't move out of the bay at jiffy lube. It turns on and switches gears but won't move forward when you hit t...
car wont start but turns over. done checked fuses and they are good. poured fuel in the carburetor and it started, I think its a fuel problem. fuel pump doesn't come on, but I checked wiring at the plug in and have no...
The car stays crank for maybe two minutes then dies. What is the problem. the alternator was rebuilt and installed but the battery wasn't charged.
The old man just replaced/repaired the transmission and it's working great with the exception of the brakes! The brakes are pulsing while driving and make a hiss-like noise when in park. Also sounds terrible while dri...
When I'm looking at it I see a 1.9 timing belt but when I called Auto Zone they say it comes up on the computer a 2.0 Is it an interference engine or not?
For a few months now my car seems to rev in the RPMs when accelerating and almost gets stuck in the gears (she's an automatic) and when I let off the gas it'll shift and then be fine. After "babying" her for awhile th...
The old man just replaced/repaired the transmission and it's working great with the exception of the brakes! The brakes are pulsing while driving and make a hiss-like noise when in park. Also sounds terrible while dri...
brake lights wont go out also sometimes i cant get it out of park.
When I turn on the AC it goes a little from the vents by the windshield, but not out of the regular vents. It still feels cold when I put my hand over those "defroster vents" or whatever they are, so the AC still work...
have a 5-speed that won't go into gear if I take the full(3/4?) circle off-ramp at any more than 20 mph. I have to pull off the road, turn it off and wait, and after a few minutes it goes back into gear.The clutch is ...
it will be running fine then it turns off
the noise it ether coming from under the hood or the dash not sure
1999 escort lose fuel pressure after 20 minutes when under load, engine vaccum is 19 in fuel pressure key on 50 psi idle 34 psi and pump driving 44 psi. car run great when cold. I have installed a new filter. Have us...
I have a coolant leak, water is leaking out between the engine and the trans axle. The leak has gotten progressively worse over time and now is bad enough to kill my starter motor. A head gasket was installed a few ye...
It seems this condition gets worse with stop and go traffic, Have replaced all electronics on engine except computer
Being as the belt just slipped iff could it have done damage to the valves? How do I ck the car runs great but wonder what damage could have been done...really need advise they say its an interferance motor..not reall...
the air conditioner doesn't work and this problem occurs when the fan for either the air cond regular air is blowing. Even when driving I can tell that the engine rev is occurring.