1,523
questions

How do you fix the leak from the sael connecting transmission to the engine and what exactly would be wrong?

The "service engine soon" light has been going on and off for several weeks. Problems have been worsening off and on yet when I take it to the mechanic, they can't find anything wrong. My car almost broke down 3 times today. The problem has been off and on, and today much worse. When I slow down or come to a stop there is a lot of chugging and shaking and after slowing or stopping, when stepping on the gas pedal it is having trouble functioning and the car starts to rumble. It is getting very stressful that the mechanic I have trusted said he can't fix it until the problem is happening at that moment. I feel like it's going to take breaking down on the parkway before they can tell me what's wrong. Any ideas? Thank you so much for your help. I need to get this fixed tomorrow. Don't want to wait any longer since it keeps worsening and I don't want to brin
Oh I almost forgot. And sometimes the problem starts when I first turn on the ignition, like the ignition won't fully fire. Then the engine rumbles a bit before I get the car driving and it smooths out for a while. I recently had a new ignition coil put in, but the mechanic said everything checks out ok when I've asked to see if the part may be defective.

We have change head gasket radiator caps took out fan and fan works thermostat change and temperature sensor

Haven't had any problems with my wagon until i stopped to grab some grub at a truck stop and when I tried to start it back up it made really bad banging noises so I turned it off. Trying to replace the timing belt thinking it skipped a tooth and was off, but i cant get the crankshaft mark to line up because its "catching" on something.
What could be the cause and would it even be worth trying to fix.

Crashed my 1999 few months ago. Unuseable but alota parts still in perfect condition. The newwer 2001 i found has been ok untill very recently the trans wetnt very bad very fast. Need to kno if its possible to take the working one out of my 1999 and put it into this 2001. Any one kno or can offer some advice? Please and thanks

It has not been working. I've heard noises from the right front, but noone else has heard it. I knew something was coming up, but couldn't decide what it could be. What am I looking at ... and could I do it ourselves ??

After the incident I found wires melted which I repaired with splices. Still only cranks. Fuel pump doesn't kick in.

A week and a half ago, i swerved off the road and hit a ditch. Now the turn signal will not blink when i switch it on for the left side. The right side works fine, and when i switch on the hazard lights, everything blinks but the left front turn signal light. I checked the bulb, and it is not burnt out. Please help!

reads fine most of the time, then reads cold for no reason.
Heater still works fine when gage reads cold.

the fluid leak look's like it's dripping out from under the pump

Trying to get heater core out I have everything apart but can't get it out . I see something that looks like clips on the heater core but can't get to them to get them off

I was pulling out of the drive way and the car shut off, I tried turning it back on and it turned over but would not start. I let it sit for 10 minutes and started it up again and it started right up but I heard a rapid knocking coming from either near the alternator or the center of the engine. Later that night I bought oil and the next day I changed my oil. Still had the rapid knocking but then it only happened when I let it sit at a light/stop sign. Later that night I was coming home from work and the car shut off and wouldn't start, had to push it home. Now everytime I start it, it will turn over but not start

I have taken it to 3 places and no one seems to figure out what it is. It starting making a loud noise, sounds like it coming from front driver's side. Like there is a bubble or something with the tire, but car place, not tire.

This car is my dad's and he asked me to look into the problem. He said he's changed the "brain," so that shouldn't be the problem. His son drove it to work a few weeks ago, but when he got home and parked the car wouldn't start again and hasn't started since. Thank you for any help you can provide.

I changed the bulbs and the signals worked on an off but now it don't work. I just want to know if I should try the fuses?

The only thing I can find is the green plastic part located behind the wheel moves in and out with the wheel. I've seen others posting this same issue but have yet to see a fix.

I replaced clutch and alternator and battery, although I needed a 100 watt fuse I put in a 90 watt. Could I have fried the alternator

while hooking up the battery, the cables were connected backwards. the hundred watt fuse, popped. Replaced fuse with a ninety watt fuse. Now battery light is on. Could I have fried the alternator or a voltage regulator somewhere?

When I'm driving up hills the light starts blinking until I return to flat surface and the rpms go up to 3or higher,and when I turn on my heat the engine starts running really ruff.

My car has 230000mi.on engine.having to fill radiator reservoir almost daily,but not radiator.today started smoking from underneath front right side .made a gurgling sound after I shut car off.heater putting out cold air