Ford Contour Questions

All Ford Contour Questions

Ask a Question
how do I fix this?? The motor resistor has been replaced.
What is the little hose pre-Molded that comes out of the air filter box called? Mine was cut
so my car stalled and got it towed to the shop. they said it was the fuel pump. it was changed and a whole new tune up, coil pack, plugs, wires ect. the car is still in the shop and they are baffled. they say its fue...
I noticed a slapping noise coming from the engine when I took the belt cover off that is where the noise is coming from.
when i drive on the expressway its starts to blink and it's losing Transmission fluid can u tell me whats the problem and can it be fix or should i just junk the car. please help me
when first taking off it shifts so hard it sounds like the engine is going to fall out,it also shifts hard when coming to a stop, a big bang, had motor mounts replace ( i was told that was the problem) so why the loun...
no air or heat on vents, this happened after car was worked on from auto garage. also i have to keep replacing motor mount (5 times already) what is up with this?
one electrical & one mechanical,according other forums. will a high mileage timing belt jump a notch? the only performance problem seems to be a small blog about the time check engine flashes on, good gas mileage, goo...
I installed a new water pump and it leaks worse than the old one.
off the EGR valve on a 1997 ford contour- it has been pinched together and I don,t know why.
my 1995 ford contour gl the oil has been disapearing fast I keep filling it but its just gone again and over heating than at the same time my radiator has been leaking and today they both fried and my car died. my oi...
car drive good normal but clutch slips when u get down on it. new clutch
no leaks no bad hoses brand new radiator new thermostat not over heating just keeps boiling out threw the overflow hose and spilling out on the ground could it be the water pump
I put some sea foam in it. thought it may be some bad gas...well that did no good... so I went and got a fuel filter nothing.... any advice???
Every so often my car won't start. Seems to be happening more frequently. All the lights and the radio come on but when I try to turn it over nothing. No sound nothing. Sometimes it won't restart for days. Sometimes ...
where is the tranny filter located on this car I found a oil pan located under the battery bracket on th side of trans. is this the loaction of the filter- inside this pan?
tried replacing the dual filament bulbs, signals work but not brake lights on either side. All other lights in working order. Tried replacing the stop light switch assembly but didn't help. All fuses under the hood...
Pulled in to get gas. Went to restart. No start. Checked fuel psi55# checked spark and replaced cause plugs and wires were due anyhow. Checked codes none present. Checked timing, power to Injectors, and compression ...
The car will start and run for on about 3 blocks. I don't know if is a broken sensor or something else
I have a problem with a tire that has a broken steel belt in it. The car sways and shakes violently when I get it up to 50-55 mph. it also loses brake power. What would cause this problem?
An electric check on NEW ECT shows input voltage at 4.6V with key out of ignition. With key-on or engine running, the input voltage drops to 0.88V. Is that correct? Could PCM be bad?