13
questions

Left home in dark and by the time I drove 7 miles, headlights had faded out. Replaced headlight switch and still no lights

Out of the blue the headlights went out I got some new ones and within a few moments of being on they went out it was like they burned out on low beams and then put them on high beams and then they burned out on high beams.

it started stalling when it got hot had carb rebuilt problem went away had a leak at timing cover they changed timing chain cover and intake gasket and water pump got it back and the stalling came back worse than before they took fuel line off and no fuel is coming out of the line when hot new fuel pump what can it be

we have done a full tune up, changed fuel filter, fuel pump, throttle body gasket ,cadillac converter, map sensor, i know there is probably more but it runs like a heep still.. Back up, it stalls,, stop anytime and go to take off,, it stalls.. its popping and fartin and just sounds BAD! Sad thing is we just got it back from a mechanic.. What could it be?? Please help!

I have a 94 Dodge Ram be 350 with a 5.9 liter engine the key will turn over the nation relay is working but it will not crank it will not start it will not do anything I'm getting power to the starter and everything but I'm not getting any kind of turnover. It started out intermittently but has gotten worse and now it doesn't seem to want to start at all

Have no tail lights now at all, no turn signals, or brake or backup lights.Fuses are all ok, cant figure this one out!

new blower resistor,switch,and a/c selector switch

Replaced a transmission for the "beast" with a used one. Van runs good while in drive. When coming to a stop the transmission does not drop down to first gear.

my mechanic has replaced computer 3xs, new distributor, replaced ASD twice. when it runs its the best its been in years, but dies. 70,000miles on van, very low mileage. he is at his wits end and suggestions on a new way to look at or check something different. any help would be appreciated.2

I need to know where the crank position sensor is located; this is a hopeful fix to this issue no one has been able to resolve; guy who sold it to me put a brand new alternator in and still had the same problem of cranking but no start constantly. I tried replacing the voltage regulator (batteries are fully charged and working when I put them in) and the computer (brain) located thru the interior engine housing on the vehicle. An auto store tech told me last nite this could definitely cause my issues, but I need to find it to replace it. Have seen on web it can be located in bell housing on transmission, behind the water pump, on crank shaft or pulley, etc.

transmission does not shift into overdrive. the light in the switch is off, pushing the switch in does not change anything, is there a overdrive switch relay that could possibly be bad. If so where is it located?

I would like to know if p265 75 R/16 would fit on my van?

i got a 35gallon tank