Runs around 2000 rooms at 60 mph. Is this normal?

I only may drive total of 50 miles a week

The acuator won't blend heat I can't get hot air only cold

Can't tell how or when it starts, I just know it is a lot of oil. No mechanic seems to know what it is or where it's coming from. Does anyone here know?

It a pears to be coming out from behind the main pulley on front of motor. Any ideas as to what it could be?

Right side of motor. Found some wiring harness has a braket looks like it use too attach by the transmission or to the back of motor wires almost worn through. Cannot find coolant leak though. Help

when running the ac or heater they only blow out of the defrost. the positioner dial when turning the positioner dial from vents to floor or any positon the air only blows out the defrost. not sure if a hose is off or if actuators arent working or if somethings just stuck.

Did a compression test there is no compression also now it's backfiring a real loud backfire what could be the problem

It was driving perfectly fine, didnt run over anything, never had a problem before, it just cut out on me, any ideas?

i have coil packs from 2 diff,intrepids i need to know if the higher the#if it runs hotter,always if hotter the engine runs better...

Oil pump is bad

Hi Team,

Let me brief the issue.
Car battery got died a few weeks ago and I started it with Jump start and it runs and as soon I am putting it on Drive mode or leaving it idle it was getting stop...

Today I got a new battery and when I connected its terminal it started smoke from somewhere near by radiator or Alternator...

Request you to guide...

yesterday/for 2 weeks fixing started w/4 codes now1-left.po152?sensor-circut high volt.bank2-sensor1all 4 sensers new...Whats a girl 2 do.....i have a obd2eobd.it comes in handy w/libary

While my car is running and in gear its like im applying breaks and it wont move. What is causing that. I replaced calipers and bleed the breaks.

held for one day...do I only use antifreeze or is water ok

Last september the car just stopped.I have been on here for this intrepid starting with grounding straps. Then no fire. Then no fuel. So I replaced pump in tank.crank sensor,cam sensor,all wires, coil pak and plugs. Several other items including ignition switch. Now I am at the computer. A friend told me special points I should check on there for voltage and good ground. It all checked out okay. When I went back to him he said, well, we know the computer has an issue. So he sent me home with another computer and the car still would't start. If I tested all those connects and got the right reading why would he consider computer to be bad. Why would he be so adamant about it. Isn't there something between the computer and coil that could have gone bad. My friend ziptie 12 has helped me a bunch with but I think he has limitations right now. Get well quick. Also 2 people have plugged their hy buck scanners in and it will not let them in. Your thoughts would be great appreciated.

It started three times then it didn't even want to crank any more. Every thing looks normal except it won't start.

head gasket enough

What price engine replacement in may area 05156,I think about it because the cost of repair exceeds the cost of the engine , Thank you Kaz

It give no problem until then, changed battery and tried to turn over slowly but could smell the starter, what could be wrong? The starter would not have caused it to just quit? I can't crank it a brand new battery, has 130 thousand miles, but has always done good, I had changed the battery about 3 months ago, it had been in there 8 yrs. cranked every time until it quit and then this happen!! Put another battery but still clicks tried to turn over a couple times but smells and gone back to just clicking!! The starter has never done this!! I need some suggestions!! Thanks!!

Itll start and also at same time all park neutral lights ect.are saying theyre all in gear wont shift out of thrid gear all just started

when I fill the car up it goes to full and as the fuel runs low the gas gauge will move. when the car is about on empty it goes just under the 3/4 mark what would cause this? and there is no code when hooked to computer.