410
questions

slightly off center or leaning

Only code po300. No oil in spark plug tubes. Will run ok, ses light stays on. Ecm .plugs are clean.

My 2010 Dodge Avenger SXT, passenger power window will not work. Motor is fine, took it out and tried it in rear and works there. doesn't sound like motor is trying to work in front when you hit the button. Tested for power coming to the switch and shows I have power in. What else could be the problem? It is not showing any codes, and don't see any fuses that are bad.

the code read at advance auto showed up as cam sensor issues. the switch was replaced, now skidding car light on dash along with check engine light come on periodically, this disables cruise control,and at 65 70 miles per hour makes car lounge like it is starved for gas?
don't have the diagnostic code now cant remember from when advance checked it. sorry. the problem happens almosr everyday, have to put in park shut car off wait then restart sometimes three times before skidding car light goes away? now check engine light has stayed on?
car runs fine acts perfect when the skidding car on dash is no longer lit up??
very perplexing and worry some. please and thank you help me? I am retired older man, and this problem is really bugging me. Has to be something simple, or car would not start continue running so well. has been driven several miles or all day after the above mentioned trouble light has gone out, been reset?

Can I install subs, and an amp with factory radio? Also, if I install new head unit can I still use the buttons on the steering wheel for volume, etc?

The tab on ours is missing and want to know if there is anything in it that would get damage from the tab being gone. It is to the right of the blinker at 1:00 on the steering wheel column. What is inside it and its function. If any.

I goes in reverse drive everything is good but it won't go to park. I have to put it in nutural for it to turn off and on then shift it to park to take key out. I have tryed turning it from top of transmission but it won't let me put it in park position.

I cannot get more than a couple dollars worth of gas in at a time without the pump shutting off. the gascap display came on a couple years ago along with the check engine light. took it in... he said replace the gas cap. so i did, the light persisted so ignored it. eventually it became more and more difficult to fill the gas tank. it started with my having to place the nozzle a specific way for it to fill and has developed into my having to just trickle the gas in in order to prevent the pump from shutting off. it takes anywhere from 15 to 30 minutes to fill it. I've replaced the gascap and have also replaced the filler neck tube since the vent tube is one with it. I'm trying to figure out where to go next. could it be the charcoal filter? evap sensor? vent control valve? (if vcv, does this mean i have to replace the tank?) I can't really keep just throwing money at the problem trying to figure it out.

thanks

Just bought a 2012 avenger. Do not have factory key. If I get out and push door lock button, when I go to get back in the alarm goes off? Why is that, and what can I do to fix it?

Right now brake goes further to floor (not all the way) to engage brakes.Brake light on continuously.

Prior symptoms are When slowly applying brakes while slowing at a stop sign the car jerks before complete stop.

Brake light comes on randomly without staying on.

Brakes make that dragging sound when braking, however, had brakes checked when changed oil and pads okay.

I have a 99 dodge avenger and for a while it would go a few days just cranking over but would not start and the next day start and run fine did that a few times now won't start at all I have replaced fuel pump crankshaft sensor distributor and still not starting any help would be appreciated it's a 2.5 v6

My brother tried to fix it without me asking him to. He put some kind of glue on it to keep the key from coming out of the keyless thing. we drove it for one day and then we had to get it towed home because it wouldn't start. All the lights came one and you could play the music but the car it self wouldn't start.. please help

What can be the problem

Brought my car in for a check engine light. Ended up having the intake manifold replaced. All codes went away, but one...the computer is showing a misfire in cylinders 1 and 4....everything is good, cam, compression, everything else. My mechanic is at this point baffled, and cannot figure out why....he says he's run every test possible...can anyone help??? He's had my car for 5 days

My wife stated that started acting weird opening and closing by itself and now the engine won't turn over not sure if jumping it will help because the lights and radio comes on and is working

Knocking of coarse and blowing oil out tailpipes badly. Oil n smoke from front lower engine

I recently had work done to my car so that the check engine would turn off. Now its off and i need to smog test my car but its not "ready" yet and ive done mny drive cycles and done almost all i can. What else should i do?

when i turn it on, it works normally, but when its parked it sounds and feels like its going to die. the tachometer marks under 1 x1000 x min (more specific at .6) and when i try to gas, it doesnt accelerate right away. it takes a couple of seconds then accelerates very fast. my car have died at gas stations when stopped or parking lots but never running.. what can it be?? whats wrong with my car??

What do I have to do to fix my car with the codes p2432 and p2257. I know what the codes mean but I don't know what to do to fix it.

Won't start. Had to pop the clutch to get home. Put new starter in and no different. What else can it be & locations to find possibilities?