Close

Chrysler Crossfire Questions

Get answers to questions about your Chrysler Crossfire at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
224
questions

Does it sound like wheel bearings or the rear axle?

It almost quite.Put old mass back on engine smooth out.Cleared check lite drove it then check lite came back on.

For no appent reason the car will just die. I turn the key and nothing happens although the electrical systems are fine. If left for 45-60 minites it will start right up. I was told that it might be the Right side Relay PCM or maybe the crank shaft sensor.My Chrysler dealer looked over the car and told me if any of the above was the cause it would have left a code. Any other suggestions before I start throwing parts at it?

Check engine light comes on for a brief period and turns off after driving awhile. Dash light indicating burned out headlamp comes on but all lights are functioning.

shifts into neutral when vigorously accelerating

i was driving and my car just simply cut off, i mean shut completely down while i was driving home? i gave it a while then it started right up..this issue just recently started and now even when i go to crank it uo it doesnt start right away.

I have a 2004 Chrysler Crossfire. Six speed manual.....Clutch slave failed. Had my mechanic replace clutch pressure plate, bearing, clutch disc and slave cylinder. He put everything together, bled the system and all seemed repaired. Drove car about 5 miles and clutch went to the floor and had to be pulled up manually. Gears would no longer engage.....Stopped on the side of the road. Burned fluid smell....Mechanic installed another new slave cylinder, bled the system. Clutch pedal appears to have pressure when the engine is off. Once started pedal goes to floor and won't engage transmission. Appears to have no pressure. He is stumped. Does anybody have a clue what the problem is? HELP!!!!!!

I turned on the air conditioner. When I reached my destination, I tried to turn it off using the controller. When that didn't work, I turned of the car and the air conditioner stayed on. I took it to the dealer, and he had to unplug it.

I have no DRB-2scanner,just a 2005 service manuals 1-3 which section 7-1 thru 7-11 sugggests it could be a fan motor, or the 50 amp fuse, or power control module and or radiator fan control module? Is there any other places to look or easier way.I`m disabled and not super auto repair knowledgeable. Thanks four help and suggestions ;Tom

I can hear a pump or motor running when I hit the locks!

When switched on, inside air conditioning blower shuts off for a few then comes on. Strange, but both seat controls work off and on also. seems like after a few minutes they work, or don't work...

The transmission stays in either low or high gear.

are both set to the coldest setting.

The last time I had my oil changed I ask for them to check the transmisson fluid. I was told that the dipstick to the transmission was missing. My oil is due to be changed again,should I take it back to tire plus. I am a single women and everyone has opions, Like there is no dipstick the the Tranny, and the car should take 8 qts of oil, they only put 5qts. in. It is low on oil and I was told i could only put synsethized oil even if it was 1 qts PLEASE someone give me the right answer. Thank you in advance for your time to answer my questions.
KITKATKAY.......katharinkknewkirk@yahoo.com

turn alarm off to leave,started car starter not turning

15 minutes after about 1 hour of trying different things it started but engine light came but now it is off!

The key dosen't turn the ignition to start the car. I have to play with the steering wheel to get the key to turn and start the car.

The RPM will fall off and I will have to pull over and restart the car and it will run fine then will do the same thing again

Thinking of buying a 2004 Crossfire with 50K miles and wondering what maintenance i should do to proactive regarding timingbelt/timing chain repair.

It clears up after several minutes I dont know what could be causing this. Car is always garaged when not being driven.

This is on a 2005 Crossfire.Replaced sensor,locking tab broke off.Is there an easy fix? Dealer wants to replace entire wiring harness,are Mercedes parts interchangeable?

The garage replaced the seals for the RagTop replaced and now it will not go up and down. It's not the switches. When trying to open the the top the light comes on red and beeps as I hold it in the open position.

Problem getting it to rotate and stay down has been slow in developing, a year or more.

Already replaced the crankshaft sensor,2 weeks ago. but now it is doing it again.Also when you start the car the rear spoiler comes up??

i used 0-40 mobile oil when i crank it up it make a tappin noise in about 5 minutes it goes away

i was at the light and i press my gas paddle to go but the car moved slowly ,like it was in neutral, and now while in park and pressing the gas paddle i have to press it to the floor to get the engine to rev up..is this cable or a line

when i start it on a cold day it makes dis tappin noise sound like it comin from d engine five minutes later it will go away it just started dodoin it

noise it didnt used 2 do dat what u thunk d problem is

The code is saying that is the crankshaft and so we changed it and we keep getting the same error and it does not start, my mechanic is saying that it is the engine computer. Rebuilding the engine computer is super expensive.Do you think is the computer? or maybe the engine relay? please help! my mechanic has no idea!

I had the problem of going down the road ,Bells lights no go pedal dead in the middle of the road!!!I just got the cpu back from Cardone they claim no parts to do the repair? I have been reading all your posts any one out there with a majic wand??