618
questions

Turn it off and then try to start it when its hot and it won't start. Try changing the cooling temp sensor or known as the cooling temp switch

My first thought is timing/cam chain. Or possibly lifters. I have only noticed it on cold start-up. My wife claims it didn't sound right at the stoplight once. The car has about 165000 miles with no major work done. No codes show.

It sounds like it wants to start but want.I ran out of gas once before but pumped the gas pedal then it started.Not sure what the problem is,did I damage something by letting it run hot?

I change camshaft position sensor crankshaft position sensor idle control throttle position Center what can keep the car from starting

Almost stalls out just after leaving driveway...hear a pop noise then is ok...runs great until you stop and starts all over again....

car was mother's. only 75,000 miles. no other issues.

Dealer determine main computer needs replacing. Dash indications goes away periodically, except fuel. BCM was replaced and was determine not to be the present cause.

While engine is running, key can be removed from ignition cylinder.
Main Computer needs replacement(dealer recommend-junk yard)

I am replacing the radiator in my Chrysler. This is my 1st do-it-myself auto repair. my dad talked me through the removal of the old radiator. Now I have the new one to install. my dad is out of town. so i need detailed instructions to install it. i am a mom of 3 sons & will get my hands dirty to learn this with the help of my boys handing me tools as needed.

My check engine light is on, could it be because I need to get oil changed?

It turns over but still wont start

car will run if you spray starter fluid in it until it burn off there is fuel at the rail there is power to the injectors don't know if it has pulse i have a code p1680 i replaced a red wire from batt to the alt it was burned someone hook cables up back word

about a 4 inch square plate held with 4 screws. Majorly rusty and need to replace

After 30 minutes of driving I shut it off and restart it ABS light goes off and everything works fine. What is the problem with it?

a hill. It stops if I take my foot off the gas. Didn't do it this morning when the car was cool, but this afternoon it was 80-85 degrees out and it did it on the way home.

Before it would idle really high. It all started after changing the intake manifold gasket?

Thinking about dropping engine to fix flywheel only because I don't know how to get transmission back in, its really tight under the hood.