Chevrolet S10 Blazer Questions

All Chevrolet S10 Blazer Questions

Ask a Question
Sometimes it'll stall without putting it in drive. I can pull each plug wire off one at a time and it stalls,which makes me think each plug is firing. I recently replaced the coil. I cleaned the portal for the IAC and...
Sometimes it'll stall without putting it in drive. I can pull each plug wire off one at a time and it stalls,which makes me think each plug is firing. I recently replaced the coil. I cleaned the portal for the IAC and...
i replaced the fuel pump at the tank. but now still not run. i check fuel relay no power. can any one help me? yes i replaced the icu thinking tha was my problen and still dont have power at the fuel relay. please help.
fuel comes on changed fuel filter put on new coil does not appear to have spark or fuel.
Gas is good and clean and the two injectors work and fuel comes out when tring to start. All fuses good. It was running fine, parked it and tried to start it two days later. Would not start. I used started fluid, no c...
im changing the bumper on my truck and cant find where the arm brackets attach to my truck...help please
before this car wouldn't stay running lots of white smoke out exhaust did fuel pressure test it was good. changed plugs, computer, cap & rotor wires. can't get computer to communicate with the scan tool either check e...
I have noticed that when i drive the my blazer, i am having to put the brake pedal to the floor board in order for it to start slowing down? What could the problem be?
i have a S10 Blazer 4.3. The problem i am having is ac and heat isnt working at all. when i mess around with the vent switch i do hear noises coming from behind the switch. But i dont have defrost or anything. Air and...
My truck will shift into park, drive, reverse, etc, but it gets stuck in 2nd gear when you try to drive down the road. You have to punch it to get it that far, we discovered that while trying to limp it home.
it doesn't happen all the time but when it does it starts right back up. also sometimes it does it before i put it into gear. does it in all gears. Now the oil hose from the external filter to the motor leaks so it lo...
I recently purchased a 94 s-10 blazer 4.3 lt Vortec V-6 2WD Tahoe LT. Everytime I push the gas pedal I hear a whinning noise coming from the front end. It does it until I let off the accelerator. It's driving me cra...
i put the heat or air up on high and it barely blows out the vents. i don't k now what causes this
IVE TRIED SEVERAL SITES BUT JUST GET DIRECTED AROUND IN CIRCLES OR THEY SAY FREE AND ARENT!!
i have a 93 s-10 blazer 4.3 vortec high output,1 of the screw holes is stripped out,1 screw holding the cap on.if there are any helpfull steps to replacing,the distributor i could use.i could do myself,before it go...
I need to know why when I put it in 4x4 Low, it will not move when put back in drive.
replaced fuel pump, plug wires plugs, replaced distuber, distuber cap, still skiping.
I have to back up before my 4x4 engages/
THe digital dash is not working, this may be the problem. Would like to check it.
We tried a fuse, but thats not the problem.
I am having trouble removing the cylinder head.Does each come off on its own? Or do they come off together?
I have a 1991 S10 Blazer 4x4, with a 4.3L V6.. it has 193000 miles on it, but it has been well kept up. It was running just fine until one day recently I was drving down the highway and it started jumping. Then a ...
We have replaced calipers, rotor, Master cylinder, brake line, pads. Still locks up. Disconnected the ABS and that seemed worse. I don't know what else to do. Please help!
it wont even open. It is stuck/jammmed...my question is how do you get it opened?
i changed the plugs wires and cap all cyilenders have compression i didnt try the coil yet but what els could it be? thanks.
i changed the plugs wires and cap and all cylinders have compreshin so im not sure y it dont have full power can someone help thanks
Some times it goes three or four days with out a problem. I am not really sure where to start. Any help would be nice. Thanks.
hello just wondering if someone can tell me if 148000 miles is alot for that car and if anyone has had one with close to 200000 miles just want to make sure i get a good car.
4.3 TBI s10 runs very rich. Changed O2 fp-regulator and TPS. EGR is good. Ideas?