1,043
questions

Does a Astro van 2002 4.3 match up with a 2001 blazer

My sons 01 has 109,500 on it . It runs oil pressure starts off at 40lbs then after warmed drops to near 0 . After giving throttle pressure rises to about 24 lbs . It also has a small anti freeze leak somewhere ( assume its intake ) . I was told that sometimes the antifreeze gets into the oil thins it causing low pressure and bearing wear . Where do I start to figure this out ? Oil has some fine metal in it (sparkles) but not really showing any antifreeze mix. Do I have the bottom half done on it and change oil pump or look for another engine ??

Passenger side of the front end was pretty smashed in. I am bending the bumper interior liner and replacing the bolts so it will go back into its original place. Besides that, I am replacing headlights and grill. However, right when it happened I could hear the fan hitting something so I got a tow home. The fan seems to be closer to the pulleys and engine block than before and it is touching the shroud - the top part of the shroud is not damaged, but the lower part was broken and I will replace. I was wondering how to get the fan pulled back so it won't be hitting the shroud once I replace it?

Just to get this out of the way I've already checked the gas pressure, the spark, all the fuses, check for codes but the code reader says there's no codes. I ran through the whole engine it as best I can as a Layman. What else could it be somebody please help me I'm at my wit's end?

Motor cranks over,got60lbs feul pressure, no spark at coil

I just replaced the alternator in my 2001 Blazer LT and sitting idle at a stoplight for example, turning on the rear window defroster switch causes a massive electrical drain in the system. It drops from just over 14V to around 9V or so. This only happens at idle speed settings though.

No codes come up , I've seen that I'm not the only one with this problem but there has to be a better way to do a cycle on this truck without getting killed doing it . Thanks any help would be appreciated !

No engine light on, will it pass smog test? It's a present for son graduation

After that happens the battery needs jumped and then it runs like a champ... Need to know where to start to fix it

started every day but when rain or damp out runs but actes like missing now today wont start rained turns over but wont start

I drove my SUV home from work and parked it went to go to work and it wouldn't start? Changed the fuel pump and it still won't start? The 2002 chevy Blazer LS 4door 4x4 has a different ignition and a wire hanging out below which if pushed in and turned wont allow gear shifter to move !?!

going 20 to 30 mph the rpms go up and down from 1000 to 2000 rpms . the engine does not rev up or feel like its bogging down. only thing i noticed is that the steering feels a little hard. powersteering pump is not whinning . could the pump be causing my rpms to go up n down?

I'm leaking coolant and it right under a.c. on driver side. Ever time I fill radiator it leaks out near the valve cover gasket. I checked them they were good. What else could it be.

It will turn over now but will not start

and a constant beep started. I took out and tested the alternator *- no problems. Charged the battery full - checked fuses -still no clue- no shorts in alternator wires. Any Ideas ?

It started out splattering. When pressing fuel pedal. And when it was up hill or the gas got low.. the same thing would happen or it would try to shut off. Like it wasn't getting gas. Just to crank it I would have to prime it a few times and feed gas constantly to the throttle. Next thing u know I'm driving home and the fuel line underneath my driver side popped loose and oil was coming out. As black as ever. After cranking it and it running for a few minutes I had no problem cranking it throughout the day. But if there were prolonged periods like over night I would have to feed it gas again while someone pressed the gas pedal. Or if it got hot throughout the summer it would seem to be missing and jumping. It also drank lots of gas. More than usual.

Does the gas tank have to be dropped?

What does the part look like? Can you please let me know what I need to fix this problem?