1,059
questions

my radiation hose had a hole reparative and now car will not stay on without hitting gas whywhy

ABS at low speed is engaging , is it a dirty sensor ?

when coming to a stop, brake pedal feels mushy and can hear a grinding noise. can wheel sensors malfunction cause this

Won't start again. I've put new crank sensor on new plugs, new wires, new distributor, its getting fire, air, gas what can this be

Happened simultaneously. Was fine put car in park and brake pedal went soft, couldn't roll up window.

electric door lock does not work

I was driving home from work when truck stalled. Now wont start. I ran it outta gas a cpl times the week before so thought naybe fuel filter was clogged. Changed that still nothing. Fuel pump kicks on but sounds a little whiney. It starts if i spray either into it for a second then dies back out so i know its getting spark. It is also getting fuel to the fuel rail relief valve so i know the fuel pump is working. Anyone know what this could be and what i should try next? Please help

My brakes went to the floor, I had a new master cylendar installed, the same thing happened again. This has been going on a while Like 3 months The car will stop but slowly. My mechanic has tried everything he knows and is baffeled he cleaned the sensore on the front wheels.. What else can we do?

Always does this. After I go somewhere and stop car, the same process will repeat. Is this a anti theft problem and if so, how do I fix, bypass, or whatever? Key doesn't have a chip.

My power locks and mirrors are not working and I can't open my hatchback please help..

I have a 2001 Blazer and I'm having issues with it starting. I'll try and get it to turn over and it does nothing. Afterwards, I discovered a large amount of clicking coming from the transfer case control module while I was replacing my ignition control switch(which is apparently fine). I tracked the sound to the transfer case control module and am wondering if this is the culprit of my issues?

Replaced engine , now ABS light goes on then off . Never did that before also check engine light . Noticed the Alt. isn't putting out like it did before ??
Ground ? Any idea's ? Thanks

Does a Astro van 2002 4.3 match up with a 2001 blazer

My sons 01 has 109,500 on it . It runs oil pressure starts off at 40lbs then after warmed drops to near 0 . After giving throttle pressure rises to about 24 lbs . It also has a small anti freeze leak somewhere ( assume its intake ) . I was told that sometimes the antifreeze gets into the oil thins it causing low pressure and bearing wear . Where do I start to figure this out ? Oil has some fine metal in it (sparkles) but not really showing any antifreeze mix. Do I have the bottom half done on it and change oil pump or look for another engine ??

Passenger side of the front end was pretty smashed in. I am bending the bumper interior liner and replacing the bolts so it will go back into its original place. Besides that, I am replacing headlights and grill. However, right when it happened I could hear the fan hitting something so I got a tow home. The fan seems to be closer to the pulleys and engine block than before and it is touching the shroud - the top part of the shroud is not damaged, but the lower part was broken and I will replace. I was wondering how to get the fan pulled back so it won't be hitting the shroud once I replace it?

Just to get this out of the way I've already checked the gas pressure, the spark, all the fuses, check for codes but the code reader says there's no codes. I ran through the whole engine it as best I can as a Layman. What else could it be somebody please help me I'm at my wit's end?

Motor cranks over,got60lbs feul pressure, no spark at coil

I just replaced the alternator in my 2001 Blazer LT and sitting idle at a stoplight for example, turning on the rear window defroster switch causes a massive electrical drain in the system. It drops from just over 14V to around 9V or so. This only happens at idle speed settings though.

No codes come up , I've seen that I'm not the only one with this problem but there has to be a better way to do a cycle on this truck without getting killed doing it . Thanks any help would be appreciated !