My AC won't work in the front. The rear will work, front will if you are driving on the highway. The blower motor has been replaced still won't blow out the front unless moving. What do I do now? Rear air suspension goes down especially on the drivers side (when cold, rainy or sitting) sometimes it will stay up and others it won't air back up. Usually have to sit and let it run before driving so that it will air up. If there is weight in the back it tends to not air up or if it does it takes a while longer. How do I fix this?

When I come to a stop it sounds like medal to medal, on both sides of my front brakes. I have had both front bearings and hubs replaced, all new brakes installed. But still sounds like medal to medal
and is very loud.
I disconnected the ABS and
the grinding stoped. I still have good brakes. Do I have to replace the whole ABS system? What do I do?

The rear end of my 2004 Buick Rainier is sitting low. The air pump comes on but nothing happens. If I try using the air outlet on the inside of the cargo bay, I don't get any air. Would this be a sign that the pump is dead or that there is a leak in the air bags and/or air lines?

I just had transmission fix was input gear . So I'm sure battery was unplug , what could have happened

Head lights, park light, dome lights will not shut off after engine in cut off.
Then sometimes the light will not come on. What could be wrong and an
approx. estimate.

Lights are staying on. Last night had to unplug battery cable Then at time they won't come on. This is intermittingly.

We tested the blower moter and it's good it worked on the feet and windshield for awhile now that doesn't work either

also, grinding in front left wheel. bearings? what size socket needed . its a large nut .

when temp outside dips below 80 degrees cold air returns

Air will come out the defroster and feet but not out the vents. No issues with fan speeds or volume of air.

Still has power to the rest of the vehicle , after it cools off 15 minutes or so will start back up and run normal for a while

It makes the sound everytime when I make a turn.It was recently check, new rods have been added and the brakes all replaced.

Our rear air suspension leaks air all the time. When we turn car on it airs up but shortly after our car is sagging again and driving like a low rider. It is really bouncy and uncomfortable, not to mention super embarrassing. After doing research it looks like this is a very common problem. So There should be a recall. Is there a way to complain to the company so maybe they will listen and do a recall on this. Becuase it is very costly to fix.

Blower motor stays on

What do it look like.

none of the parking lights work on my vehicle. I have tried replacing the relay underneath the rear seat. that did not solve the problem I cannot find a fuse anywhere in the manual for lights work fineheadlights and tail lights work fine but all parking lights, and the side light when turn signal is on are not operating any suggestions?

Have the system bled off and one bag almost out...trying to get line out of the top of the bag

first blower started to go off intermitently now wont come on at all.

Rear blower works.

Freezing here! Help!

Cant afford to be buying electrical parts if not the problem.

Could it be as simple as a resistor?

The bags were replaced 1 yr. ago. no other parts were needed. 190,000 mi. It went down again and would not pump back up after driving, could not hear pump working. I parked the car for about a week. I started the car today it pumped up. Any ideas as to why it would not pump up while I was driving it? It may leak down overnight or it may take a day or so to leak back down. Suggestions please. My intentions are to keep it as a second car.

The Check Engine light (code C0035) is the left front wheel speed sensor. ABS light is NOT on. How do I test the sensor? If it is reporting a valid error - What are the possibilities? What are the possible solutions?

2005 buick ranier cxl 6 cyl been like that for 2 weeks or more now ..replaced dim bulbs wont come on, old ones were fine , but new still dont work,i have brights tho, what could be the problem ? checked fuses replaced , still no dim lights , very frustrated , love my ranier , not so much now tho .also heated seats back only works on drivers side ,been 6 months now no one knows what can be the problem . no seat bottom heat > cant find fuse for them ,is there a separate fuse for bottom and back heated seats ? help please,,FRustrated in ga ......