1,121
questions

I Turn engine off and start it again will work ok until it do it again.

when putting in gear stalls, when putting on brakes stalls , without turning on lights parking light are on ., Help! Done put $2000.oo in and no results.

Just bought the car 2weeks ago temp gage just started going up and down and now my heat only works.sometimes.

After it comes up the window will not go down again until it is started again

No burnt fuses. All lights and cruise work.
Replaced relays. The darn turn signals just wont come on, not even light up on the dash.
What else could it be?

It's been about a month or so that it's been happening. It's only at night that it's a problem as there's no problem seeing the speedometer during the day.Thank you.

Changed the front tires the same day lights came on. Tried disconnecting battery to reset computer but the lights come back on. What can be wrong

I'm unable to see the mileage on my car. Everything else is working fine.

Our car was towe and when we got it back it was hard to turn left really had to pull stirringwheel. While trying to find out why, driving it now the stirring wheel locks n now it's hard to turn at all

The blower works and operates fine, but the temperature of the air doesn't stay hot. It works sometimes for a few seconds at a time, other times for a few minutes. In the morning when it is colder out it doesn't work and my low oil light comes on. In the afternoons when the temperature is around 50 it works no problem and the low oil light goes away. I recently learned I need to replace the inner manifold gasket due to a small leak, but the shop estimated it would be months before it needs to be done.

Have been told its the head gasket - sound correct? 70,000 miles

Have been told its the head gasket - does this sound correct?

How much will it cost to repair?

if i remove gas cap there is a dramatic change in my car, it wants to quit. when i put gas in it and then replace the cap I have to almost keep my foot on the gas to keep it from dying. and it remains like that for about the first couple miles after putting gas in car. this is the only time the car acts like this.

Pulled ignition celanoid fuse. It shut off the alarm but then car wouldnt start.