Acura TL Questions

All Acura TL Questions

Ask a Question
I had an engine transmission mount replaced on 1/2013. I believe all thoe mounts need replacing.
No heat produced, blowers operate normally. Thermostat was replaced in Oct.
Headlight will blick on then go out. 300000 + miles engine and body still great
Started car previous night and radio would not work, anti theft light on radio blinked while car was running. This morning car started right up but again no radio. Left work tonight and turned key in ignition and not...
I have recently got an engine code P0222 throttle/pedal position sensor switch B circuit low. I have changed my throttle body and my accerlartor sensor pedal, both from the dealer. I had an aftermarket intake and I re...
I threw a spark plug and broke the ignition coil. Have a feeling I stripped the threads in the head. Acura dealership recomended rebuilding entire motor, and while I love my car I'm not gonna put that kind of money in...
This happens everytime I run a quick errand. I can't even turn the car off at the gas pump or I'll be stranded. The spark plugs, coolant temp sensor, egr valve, and main relay have been replaced as well as the intake ...
My 2000 TL will not start after I drive it for awhile (it is not overheating by the gauge). I have to wait about 10-15 minutes and it will then start somewhat rough and then it is fine. I have inquired about this with...
A 2007 TL, with 128k, power steer is tight at stop or low speed, there is some oil near o-ring (near the belt). Just had the regular B1 service, dealer suggested to replace all power steer rack, cost ~$2.2k. How I kno...
It overheated a while back but was done them started sounding horrible when starting. It had no power when starting and you hear a rattle coming from thxe exhaust. I'm stuck out in the middle of no where and need to...
I have had an issue where the headlights will not turn on...they work because they will be on and if I turn the car off and then go into a store and come back out they will not work, the turn signals don't work either...
When my lights are on my tail lights do not work, but when I push the brakes the brake lights will work...I have looked at the fuses and they are fine...I actually juts noticed the problem don't know how long it has b...
heater from blowing hot air? WINGMAN LUBE M.F. TX> left my hood open during an oil change it blew OPEN DOING 70mph, lots of expense cant afford repair bill right now. Please help Im FREEEEEEZING