Close

Acura Legend Questions

Get answers to questions about your Acura Legend at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
211
questions

Just started this morning

The compressor is good, the ac has freon, all the switches work and just replaced the ac-radiator fan switch in the passanger side. I'm lost

water pump, timing belt, head gasket, radiator have all been replaced. Thanks

where is the water pump located, on a 1991 acura legend?

i need to change the water pump.

you have to hold the key betwwn start and the on you hold it and it runs reat you let go and it will die any ideas would be helpful thanks in advance....

its a 91 acura legend

I was drii and it just stoped it has water and oil but wont start or shift out of park

just trying to see what all needs to be done

1988 acura legend Coupe, The tachometer stopped working, motor has hesitation, and stalls when I put the car in reverse a couple times and started back up after 15 minutes, check engine light comes on after 10 minutes of driving, I cleaned out the terminals on the shift position console switch which since the dashboard display doesn't show what gear its in and the car appears to be always taking off from 2nd gear on, when gear is put in drive or S3 no difference, when I start the car the computer under passenger seat and footboard both flash light once

My car is an automatic and it drives ok for the most part but it does tend to be jerky between gears 1,2,and 3 there is no strange noises or anything but the D4 light is blinking should I be worried ???

No heat til car been running 20 or 30 min. Replaced thermostat, coolant temperature sensor and 2 hoses. Overflow bottle is nearly full. Runs at normal temp for a few minutes then temp gauge goes up to redline for just a few seconds and then back to normal. Lost all my coolant for the 3rd time...Besides this the IACV needs replacing as the engine races up and down in Park.

I need a price.

An my cruise control botton light stays on an my horn dont work ive checked all fuses and relays please help me

I have noticed black sticky drops on my garage floor and lite grey smoke coming out my exhaust once and awhile.
My car is a 1994 legend 6 speed coupe with type 2 motor

when I trun on the car the light still on longer then it did before

The engine is not getting enough fuel to keep it running.

sometimes when i try and start her up, the ignition sensor or whatever it is does not read properly and she wont start up. I than have to unplugg the negative from the battery to let it reset. This is the best that i canexplain this problem. how can i fix this?

Can any one help me Florida is very hot this time of year .

there are like two or three vents holding the heater core in place, how do i get it out?

the battery and alternator seem OK, but the engine wont catch. This only happens when it is over 80 degrees. Could this be a fuse or a relay?

Battery dies repeatedly because the cooling fan is coming on at night and draining the battery

The problem has been there for a bout 2 months now. It just keeps blinking and it makes the engine sound like it has asthma.

could i have gotten the wrong half shaft

I've done changed the spark plugs and spark plug wires, and also the distrubiter cap

Once I crank it up, it will stay on for 5 mins and then cut back off. And once it does it won't crank again for 24 hrs. and do the same things all over again.

11/10/2011 replaced the battery cause car wouldn't start. Started to have issues with dimming lights. Eventually led to car dying and not starting again. Replaced the alternator. Got lights and sound but engine does nothing. Any suggestions?

alway's idle at 1500 rpm

I have no defrost it used to come on once in a while out of the blue but now it seems to never want to come on now that it is cold. Is there an easy solution to troubleshoot the control panel or blower motor? I have checked the fuse and it is fine. It also seemed when it did come on that the speed was only 1speed like medium. I would appreciate the help it's too scary to drive with no defrost and it is my only car. Thanks

I have a 90 Acura Legend L (automatic). I was driving to a new job (uphill) and all the sudden the engine light came on and the car started dieing when I pushed on the gas. I was able to drive it back home. When I got it home I tried starting it up and it would act like it didnt want to turn over. Once it did, it would idle rough and try and die. When I push on the gas to go, it dies.

I checked the self-test and it flashed once. I changed the front O2 sensor and then check it again, it flashed twice. I changed the rear O2 sensor. I also changed the spark plug and wires along with the fuel filter and still same results.

I was told possibly my distributor so I changed that today. Now since I changed it, it wont start at all. It act like it wants to but wont turn over where before it at least did that.

I checked the spark on the spark plugs and it sparks but not at a normal spark; very low, dull spark.

Could I have done something wrong when putting it in or do you think the ignition coil is now bad?