24
questions

what causes this problem

I have a 2003 sunfire 2.2 ecotec automatic lately it has been blowing the brake light and signal fuse. What would cause this. Also just today i was driving my car and not sure what happened but the transmission will not shift from second. It goes into park reverse and nutral perfectly just when i accellerate its stuck in second what would cause this please help

The shop said the whole dash area has to be replaced to fix the "knob" & I can't find any information about it.

Under the hood?

Or when im barely going its like it has trouble going like a major loss in power

Charged the battery no change. Changed the alternator and battery light still on. Any ideas? There was no light on prior to changing the starter.

WRONG WITH IT

Video on line that could show n
Me how

CAR WAS DRIVING WENT TO START NEXT DAY AND WOULD NOT, FIGURED OUT IT WAS THE TIMING CHAIN, WHEN OPEN UP, THE OIL GUIDE WAS IN 3 PIECES BOLT WERE WORE RIGHT DOWN, SO REPLACED EVERYTHING.. WENT TO START IT LAST NIGHT AND NOTHING.IS IT MORE LIKELY WE HAVE THE TIMING OFF, OR A BENT VALVE? THE MOTOR HAND CRANKED WITH NO PROBLEM.

It occurs at random times. It's happened while backing up, and when turning right.

Its more like a drip than a leak, one drop every 4 minutes.

If water pump how hard to replace. Can I drive it, none of the warning lights come on?

This only happens once the brakes are hot. Have put two sets of rotors on, re-machined them, several sets of pads, semi metallic and ceramic and replaced a caliper (reman). If I gently apply it doesn't make a sound. But when I apply the brakes normally it happens. Almost sounds like a over stretched spring noise, if that makes sense. Not sure where to go from here. Driving me nuts....