22
questions

It will Rev constantly and I looked in the carb, the carb is constantly spraying a lot of fuel once the car is cranked. How do I fix this?

it chugs when accelerating between 30 and 40 almost like trans. slipping and again 60 to 70. sounds like a hard knock. replaced spark plugs. try to get code but when shut off turn back on engine light off

ran fine befor no warning

there are other problems, like the turn signal lever with the cruise control is broken off with the wires severed.

Engine will not restart unless you put accelerator to the floor. Acts like it is flooded. After start it idles rough and wants to stall. After it sits for awhile it will start & run fine for approx 30 min then problem repeats.

Note: Check engine light illuminates after 3 min. Pulled the code which was #12

Many thanks,
Larro K.

found it on the fire wall but can't find out what it controlls

I've replaced the fuel pump (twice)7 fuel filters, 2 strainers, idle air controller, maf sensor, spark plugs and wires, throttle position sensor, fuel pressure relay, fuel pressure regulator, some vacuum lines. Car ran then loss power, limped to the side of the road and died, hasn't ran for more than 10 seconds at a time since. Gas tank was dropped, cleaned before the 2nd fuel pump was installed and 7th fuel filter. Car drove fine for about 20 miles then loss power and died, has ran longer then 10 seconds since

I've replaced the fuel pump (twice)7 fuel filters, 2 strainers, idle air controller, maf sensor, spark plugs and wires, throttle position sensor, fuel pressure relay, fuel pressure regulator, some vacuum lines. Car ran then loss power, limped to the side of the road and died, hasn't ran for more than 10 seconds at a time since.

I changed the timing belt in a 1991 Pontiac sunbird se 2.0 L 4 cyl. got the marks right,it won't start,caan you help me please. Thank you

I need to know how to do this

No drips under car where parked.

I have checked the fuses and the coil looks to be new, I have checked spark coming out of coil and there is none, any Ideas what it could be? someone else had this car and took it apart, hopefully it is something easy, Please help I want to fix this for my sister who needs a car fast, thanks

most are inside the alternator but this one is not. i have been told by several that it is whats wrong. i have changed both the battery and alternator

Replaced alternator and battery. Both still test good. Car will run on charged battery when it dies the car stops running. It will also run when jumper cables are connected when you disconnect them it dies

Its a 91 Pontiac sunfire since this has been happening I hear a rubbing noise can you please help?