Close

2004 Mercedes-Benz ML500 Questions

Get answers to questions about your 2004 Mercedes-Benz ML500 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
10
questions

The dashboard doesn't light up, and the gauges don't move... So I'm wondering if it's quite possibly a "Fuse box issue", or maybe a "battery" issue (but it's DEFINITELY an electrical issue)


AMG ML55, alarm go's off in hot sunshine.

July 04, 2014, 07:14 AM

I have disabled the "Glass breakage & tow away" sensor in the trip unit but the alarm still went off in hot sunshine. I assume there's a problem with an interior temperature sensor, how do I find the sensor? I am locking the car manually okay without arming the alarm. Appreciate any suggestions. Mike.

I have disabled the "Glass breakage & tow away" sensor in the trip unit but the alarm still went off in hot sunshine.

I assume there's a problem with an interior temperature sensor, how do I find the sensor?

I am locking the car manually okay without arming the alarm.

Appreciate any suggestions. Mike.

I have a 2004 ML500 and when I try to lock the doors the right rear door lock activates 3 - 4 times but doesn't lock.

it is blowing hot all of the time. Freon is full, compressor is on. We changed the heater control valve and it still does the same thing.

The radiator light is on, the ac is not blowing cool air, and it's running a bit hot. The fan isn't circulating ( unless I'm on the freeway).

The car (ML 55 amg) will cold start without any problem, after 5min driving it then cuts out and will not start before 10m has expired. It started doing this only every now and then, the intervals have become shorter, I now can only start the car and cuts out after 2min.