Close

2005 Mercedes-Benz E500 4MATIC Questions

Get answers to questions about your 2005 Mercedes-Benz E500 4MATIC at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
18
questions

How to lower the rear head rests.

i don't hear the whining noise when I'm driving the car but several neighbors have brought it to my attention. Any ideas?

labor rate and charges to replace pass side headlight assembly i purchased headlight assembly myself

egr malfunction,why?

and says to be only one owner, asking $8000- Dlr said station wagons like it are rare.
Thanks.

I'm thinking there is air in the tank, because the fuel shut off early at the gas station pump. It seems there is air in the tank that is not getting displaced, when liquid fuel is filling the tank. The problem is spastic and can happen at every fill up or not at all. This is why I think an air bubble is being trapped in the tank and sometime it is not. Otherwise, WOW! What a car!
Any ideas?

i just had new seals placed in sensors and pumps

When I pull out of my driveway in the morning and turn my steering wheel all the way to one side, the car makes a stuttering noise and it seems to be dragging. It was a very small noise at first and over the past 6 months got louder. The funny part is that this noise goes completely away, as soon as the car gets warm. After driving it for ca 15 min I can neither hear the noise nor feel the dragging in the front. It is not a clicking, it is more a stuttering dragging noise.
Had it at two different dealerships and one independent European car shop, they told me three different stories.
1. Thought it would be the CV joints (however, car has only 50,000 miles on it and 2. guy told me that is highly unlikely with so little miles.
2. Guy said that it could be something with the transfercase fluid and that I should simply get the fluid flushed and exchanged.
3. Guy is telling me that it has something to do with axle shaft and traction control system.
Ok, three people, three different answers. Still don't know what I should do with this car.
Anyone has another idea or had a similar experience. I would appreciate it.
Thanks.

Our 05 e500 has an in dash cd changer that rercently began to run as if it was trying to play a cd but their are no cd's in the changer. It will run for a few moments, then it will stop, then start again. Sometimes the cover plate will not close when you press the button, then it will close after the car has been turned off for a while.

Why doesn't the transmission engage after having the transmission fluids changed?

My dealer has recommended that the fuel filter in the tank be replaced. Is this necessary? I was under the impression that those filters are permanent.

Noticed this a few days ago... After sitting overnight, I got in and turned the key... Everything lit up fine (dash, display, etc.) but the car didn't make a sound. Turned it off and back on and it started.

I parked at the office and came out at 5pm and the same thing happened.

Over the next couple of days, I noticed it was more likely to happen when the car was cold or had been sitting for 6-7 hours.. A few times I had to try 3-4 times before it started. When the car's been running, it seems fine - no problems.

This leads me to believe I have a weak battery, but I get NO battery warning lights, no "consumer" messages, no dim lights - no other signs/symptoms

I replaced the battery today with a Bosch - simple swap and hope this resolves the problem.

If anyone thinks it might be something different, please let me know (hope not, the extended warranty just expired)

Thanks