Close

1999 Mercedes-Benz E430 Questions

Get answers to questions about your 1999 Mercedes-Benz E430 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
34
questions

I took the car to Burke Center Exxon, who have always provided reasonably priced and competent service to me. They charged the compressor, but found no electrical power going to compressor. Fuse and relay checked out. Any ideas? Will a non-Mercedes shop be able to read Mercedes computer codes? Thank you.

no codes. car was running died out and wont start.

My key won't turn or make the click noise when I insert the key.
Does anybody know what may be the problem?

With the exception of Secondary Air. I've driven the car over 150 miles since battery replacement. But the Secondary Air refuses to set. Any suggestion on how to resolve this issue? I'm in Cal and Smog inspection tech, the one failure bars me from a satisfactory report. Thanks in advance for your time and consideration on this matter.

my old key from my mercedes e430 stopped working. I purchased new key and i need to program it , so i can turn on the engine, open and lock the car with my new key.

150,000 miles .Never had any problems from this car . When it starts it acts like it is fuel starved . Im getting a large BAS notification in the information center

When trying to enter the radio code, nothing changes on the radio display. "Code" continues blinking.

Have tried to reset, held buttons and switches down and all at once. Tried to erase memory. Can not get the seat to move forward, back to recline. It does it's own thing and sometimes opposite.

It happens more when outside temp is hihher.

I replaced the batteries but still don't work.

Starts with surge and then a high idle. Codes are P0110,P0100,P0136,P0604 & P1580. Replaced MAF, Pedal position sensor, throttle body, brake light switch & spark plugs. If the pedal is depressed fully when starting and run wide open, the engine will smooth out and then run normal with lower idle, acceleration, and run fine.

E430 will only accelerate to 1000 and 1500 RPMs. On start it revs to 2500 and back to idle. Changed the accelerator pedal sensor. There are no codes stored. The BAS and ESP lights are on. Brake lights work. And it runs smooth not rough.