Close

1998 Mercedes-Benz E430 Questions

Get answers to questions about your 1998 Mercedes-Benz E430 at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
30
questions

when driving regular speed the car kicks back/jerks only once. It doesn't do it often but i realize it needs checking out. There are no diagnostic codes that appear when this happens. Could it be the oxygen sensor?

I pushed the lever on the passenger side but that does not do it.

Anyone know why the max is coming from the speakers so low? I can barely hear it! When I turn the volume dial up I can hear it come in and out. Don't know if it's a amp issue or if the dial is stripped on the radio. I just bought the car and had to reset the radio so maybe that has something to do with it?? Trying not to spend money by taking it to a dealer, want to fix this myself, and with your help of course. Thanks in Advance.
It's the stock radio and has the bose speakers.
Noticed the cd changer has been removed as well as the phone from the arm rest.
Also the rear window shade is not working.

I just bought a new battery. Every now and then it does turn over and start. But then when I turn it off, the problem reoccures.

It idles fine but won't rev up.

infared key

nut (behind the fan) clockwise or counterclockwise?

New regulator lasted 2 hrs and turned the car off and fan keept going and lost control completely, had to diconect fan to turn it off. What should i do. Please advice.
Alejhdez@hotmail.com

Problem is worse at start up but never quite goes away.

under my hood i found the control panel for the fuses... there is nopaper work to indicate what fuse goes where ,what size fuse and why.

The fan stopped working abruptly and the next morning when we went to start te care the battery had gone dead due to what seems to be a fan that was stating on after the ignitionwas turned off. Please advise on this ..

Blower work good on both sides and I have tested all flaps.

replaced the gasket and the timing expansion cover its still leakin so wht do i do.do i just gety gasket sealent and goop it on.i think the default must be on the timing side but i dont want to replace that.not to mention this leak sprung up out of nowhere wqithout anything causing it that i know off.hhhheeeellllppppp