21
questions

Put on new head, water pump, and timing belt. The engine was running better than it has since we bought it. About a month later my wife was on the way to work when suddenly the motor just quit. Towed it home. Now it will turn over and sometimes sound like a cylinder might try to fire, but nothing close to cranking. How to proceed from here. It has fuel pressure at the rail but the code is 1167 indicating fuel sending unit is a problem. The gauge is definitely erratic. Can this cause the problem?

I found wires coming from the egr valve down into a tube that had old tape coming loose. I replaced the tape & it seemed to help but it still hesitates on acceleration.

my motor spun a rod bearing and found a running 98 acura car with 3.2 , need to know if it will swap out

Just buy the truck and i had to change 4 oxygens sensor on two pipe. But i don't see the old catalytic and where to install them, They told me to buy two catalytics

started to hear a loud "punch" noise when breaking and breaks are not adjusting accordingly, seems like the car is not stopping! This happens when it rains, I'm so scared to drive my car now specially when I have children in my vehicle. I'm petrified to drive it..! HELP!

it hesitates and stutters at lower rpm when accelerating but clears up around 2200 to 2700 rpm.

You can email at levi.cureton@yahoo.com

99 Amigo 40k miles, never had Auto Trans Fluid Changed or Trans Service..delay in 1st Gear and comes out of gear in 1st as well at times. All other gears are normal and smooth. Any ideas? Maybe just a trans fluid low, need check and service? Electrical something? No lights on dash ever for failures. Any kind of adjustment within Trans to fix? 6cyl Automatic.

It feels like something shifts its position just as the car stops...then shifts position again just as I start moving again. It's not something in the car, but under rear end, it feels.

I bought this car not running and was told the computer is bad. I want to be sure that is not a bad ground or fuel pump. I checked the fuses, the fuel pump does not come on with the key. I also tried some starting fluid and it made no difference.

light flashes and gauge goes up and down

engine light was on ran a scan it said o2 and no.1 ignition coil was bad replaced both engine light is out but car wont start sometimes it will crank but not start