i am wondering what types of motors can fit in my 1993 isuzu amigo would a ford ranger motor fit in my car

I had recently replaced the fuel filter and fuel pump on my 93 amigo, 2.6l. The engine will run for about 30 seconds and stop, not starting at all after that. If I let it sit for awhile it will do the same thing. Any help would be appreciated. It hasn't jumped timing, it runs perfectly for about 30 second. I can push the accelerator and it will tach up normally, idle normally then cut out. The relay is good, don't know what could be wrong.

i put gas in it but when i did i used a karaseen can but it apppear to be dry if this is it how do i fix it

i ran out of gas and i putt new gas in but wont start please help me need to get it going please and before this every other day i would have to pop the clucth to get it going
i got it to fire with ether but then a heard a loud popp like a fire cracker then it wont fire at all

I bought the Car and the lights were already on. So i changed the O2 sensor but the light never went out then i dont know how to get the other lights out Please Help.

Found the distributor had came out (a bolt that holds it in came out) I placed it back in and checked spark with a tester and I have spark. What would i do next. Thank you for your time.

The eng turns over freely, but will not start. This started when I was driving on the freeway. I was doing 55mph and then all of a sudden the truck loss power. The truck had a muffler leak just to let you know incase this is tied in. Thank you for you time.