Car Problem Reports

Oldsmobile Cutlass Supreme Failed Fuel Pump Can Cause Engine to Stall

 
Oldsmobile Cutlass Supreme Problem
13 Reports
Me Too
Edit

Model Years Affected: 1990, 1991, 1992, 1993, 1994, 1995, 1996, 1997

Engine Affected: 3.1L V6

Average Mileage: 117,000 mi (112,000 mi - 120,000 mi)

Verified

The fuel pump may fail causing engine to stall and not restart.

  •  Rookie

    Ive owned this car for a year and a half. Whn first bought it ran fine for test drive then after buying it wouldnt start. It started the next day was taken to a shop where they couldnt find an issue, it ran fine. Since then I have had intermitent issues with running good except for slight idle roughness when sitting at traffic lights. Then it started having the same issues as earlier where it would run ok and drive somewhere and tun it off and few min later wouldntstart. Wait a bit go back and it would start right up. Then same thing would happen. We have replaced the fuel pump. Since then it has started several times. Then I went to drive it and it failed to start. Replaced the fuel regulator, still won't start. My mechanic is stumped. So am I. Not sure what to look at next.

    Flag This
  • Visitor, , 3.1L V6, 119,000 mi

    Ive owned this car for a year and a half. Whn first bought it ran fine for test drive then after buying it wouldnt start. It started the next day was taken to a shop where they couldnt find an issue, it ran fine. Since then I have had intermitent issues with running good except for slight idle roughness when sitting at traffic lights. Then it started having the same issues as earlier where it would run ok and drive somewhere and tun it off and few min later wouldntstart. Wait a bit go back and it would start right up. Then same thing would happen. We have replaced the fuel pump. Since then it has started several times. Then I went to drive it and it failed to start. Replaced the fuel regulator, still won't start. My mechanic is stumped. So am I. Not sure what to look at next.

    Flag This
  • ladon, , 3.1L V6, 120,000 mi
     Rookie

    i have replaced the fuel pump on it twice,will run and do good for a month or so then it messes up again..will not start no gas coming so thats why replaced fuel pump,pump was not pumping the gas through,have replaced fuel pump a third time,now the pump working but will not start what do i do

    Flag This
  • Visitor, , 3.1L V6, 112,000 mi

    Car was hard to start. Sometimes it would, sometimes it wouldn't. Replaced fuel pump and starts right up.

    Flag This
  •  Rookie

    dont want to start when get hot

    Flag This
Ask a Question