Car Problem Reports

Mazda MPV Cranks but Won't Start, Was Running OK

 
Mazda MPV Problem
37 Reports
Me Too
Edit

Model Years Affected: 1990, 1991, 1992, 1993, 1994, 1995, 1996, 1997, 1998, 2002, 2003, 2004, 2005, 2006

Engine Affected: 3.0L V6

Average Mileage: 146,518 mi (10,060 mi - 269,300 mi)

Verified

If the engine cranks but won't start, the fault may be internal to the distributor. Diagnosis will show no spark and trouble codes for the crankshaft position sensor (CKP) or the camshaft position sensor (CMP). Our technicians recommend replacement of the complete distributor assembly if these conditions occur.

  • Visitor, , 3.0L V6, 109,000 mi

    vehicle just died while driving. will crank but not start now...was running perfect before just losing all

    Flag This
  • Visitor, , 85,000 mi

    Our Mazda MPV randomly won't start, it cranks but won't start or it starts for 1-2 seconds and quits and then won't start again.

    Flag This
  • Visitor, , 3.0L V6

    Car was running like normal then all of a sudden it died as if it ran out of gas. Checked fuel pump and filter they ok. Shut off engine and something seemed like it was still turning (Radiator Cooling Fan?). After tried starting...cranks but dues not run. Checked coil by taking wire and holding metal opened end close to metal grounded. No sparks.

    Flag This
  • Visitor, , 3.0L V6, 165,870 mi

    I replaced the distributor and did fix problem for a day. Next morning I drove the van to the same service station where it broke down and would not crank the week before and it refused to start again. The distance is less then one mile. There seems to be a correlation between engine temperature and it not starting.(Cool = won't crank back up) Now I let the engine completely warm up before shutting it down and it re-cranks every time.

    Flag This
  • Visitor, , 3.0L V6, 136,400 mi

    engine oil leak led to mechanics shop for check up.complete gaskets replaced.came home and now will not start.no electrical power to coil or distributor to ignite engine.where did the shortage occur I don't know.drove fine from the shop.out $400.00 with no van to pick up the kids.help!! yes I just changed the coil and all fuses under the hood/dashboard.

    Flag This
  • mohan, , 3.0L V6, 269,300 mi
     Rookie

    crank ok but no spark. Change crank sensor and new distrubetor still no spark

    Flag This
  • Visitor, , 3.0L V6

    Same as described by others: intermittent problem. Strong crank but no start. Often will start after awhile. Had to tow it and it stared right up after the car was dropped at the shop. Thought it was the fuel pump but mechanic said it was distributor. Another mechanic suggested a sticky air valve that causes important sensor to misread conditions.

    Flag This
  • Visitor, , 3.0L V6, 165,030 mi

    Sent to garage to put new radiator and new timing belt and front seal when I got it back it ran fine for about 9 miles then it quit all of a sudden it started back and I made it 2 miles from my house it quit again now it will crank(while cranking it sounds funny like its dragging to start whying) but will not start at all I can smell gas but it won't fire up please help me someone done spent $575 on the first garage visit

    Flag This
  • Visitor, , 3.0L V6, 180,253 mi

    vehicle sat for ten days was running fine before when i came back from vacation cranks starts and dies/now it lost all spark and just cranks

    Flag This
  • Visitor, , 143,396 mi

    The van was running great and all of a sudden it will crank but will not start. After reading some of the posts here, I've replaced the Camshaft sensor, Crankshaft sensor, All 6 Spark plugs, All 6 Ignition coils. I've checked all the fuses under the hood and under the dash, and they were all good. I pulled a code of "crankshaft sensor" but after replacing the sensor, I cleared it out. Now there are no codes but the van still won't start.

    What else can I try?

    Flag This
+ See more reports
Ask a Question