37
questions

Hit switch and heard very loud pop and then the engines revs extremely high

nemogu ponjatj pochemu zavoditsa i glohnet esli ne glohnet to pedalj gaza sama dvigaetsa oborotq prqgajut otkuda nachjatj iskatj problemu??????

even with key out security still runs.. have to remove battery cabel..tried locking doors with key no help..

I tryed to slide a cd in, it will not go in. Then I got it in then it just sat in the player and played nothing. I had to turn the key off to get it out of the player. Can the CD player be repared?

The car now vibrates all the time, even when idling. It will get up a hill but sometimes struggles to make it.

This tick is very metallic. NOT a KNOCKING NOISE! Please I can tell the difference.Tick matches valve train component speed exactly.I'm thinking cam follower.Whats inside the follower that can fail causing this loud TICK? Can I run the engine w/out camcover to pinpoint this tick? You know (old school)pushing on parts until the noise changes while motor is running?Or a good diagram showing a breakdown of valve train.This noise isn't like broken valve spring,chipped piston skirt,etc.I think theres slack somewhere in the valvetrain.Local mechanics get fuzzy eyed when I ask if they have ever been inside a northstar other than to replace a gasket.Please I'm semi-retired and on a budget.Thanks Louwelds.

THIS 32 VALVE V-8 HAS 95K MILES TOTAL, DRIVEN OCCASIONAL SHORT TRIPS, SUDDENLY STARTED LEAVING A GRAY OIL BURNING SMOKE TRAIL EQUAL AMOUNT FROM ALL 4 EXHAUST PIPES. I DON'T DETECT WATER IN THE OIL AND THE LOW RADIATOR LEVEL MAY HAVE BEEN FROM NOT FILLING IT IN A LONG TIME. HAS NOT BEEN DRIVEN MUCH SINCE THE ONSET, SO OIL LEVEL DECREASE IS NOT YET NOTICABLE. NEPHUE WANTS TO HELP IF JOB IS SHORT OF ENGINE REBUILD.

Northstar w/only 52,000 mi.Can't hear noise when sitting inside of car,but when I stand outside and rev-up the engine its pretty darn loud.Heavy tick sound matches camshaft,follower speed??? I guess.I'm guessing theres slack somewhere,like valve train,camlobe,etc.Louder when revving up and revving down,but still way to loud @ speed.Noise goes away when idling (most of the time,but not always)Maybe a camshaft lobe going flat? Car runs perfect,Ive put about 1000 miles on car. I think its getting louder but not sure.Its not worth a dime if I cant fix the ticking noise. Tryed Lucas oil treatment (1 small can)The"quiets noisy lifters" stuff. No real change.Hey you cant say I didn't try!! Fresh oil change (regular oil)when I bought car (1000 mi ago) no synthetic.

The mechanic that is inspecting the card cant figure out how to turn off the traction control which seems to be linked to the ABS so he can inspect the car

my heater core went out and i has coolent coming out under the dash and i can not afford to replace it right now so i am wondering is it easier to do it from the top of engine or from under the car? It does not seem to have that much room going from the top of engine.

car had been stolen when returned the key ignition had been broke up and the collumn had been tampered with.

The cooling fans on the radiator don't turn at all. Unless they are directly hooked up to 12v. Since they both operate off of relays would it more likely be a sensor? Which one and where would it be located?

Not miss firing, runs good to that point