saftey mode. what could the problem be. it starts goes into reverse, will go into drive but wont drive above 30 miles per hr for the most part

When my fuel indicator goes to just below the half mark my glow plug light flicker on and off and if i dont top up my fuel it just cuts out ...like it is just been starved of fuel..when i top up after some time of turning ignition it fires up

After driving a little while and my engine heats up the dashboard cluster starts beeping and the oil light starts flashing. At first I thought it needed oil but didn't. I don't understand what the problem is. .

Just bought. Needs alternator (killed battery); replacing tomorrow and already have new battery. Rear suspension is up, front is down (remains this way with car running and also while off). Start the car: does not self level, compressor does not engage at all, ESP switch controls in dash do not illuminate (no power to switches). All fuses are still good with verified power to them. Was thinking originally there was a leak but now seems to be an electrical issue. No codes.. however, the dummy light is on in dash for air system. Any ideas and or direction would be very much appreciated. Thank you for your time. Good Day

Check engine light is on but engine runs like a top. The mechanic said he needed nearly $3000 to do this- more than the car is worth.

I just bought a used 2003 Audi allroad and I was warned b4 I put the car on a lift at a a local macanic shop I have to shut off the air suspension or the airbags will blow. Problem is I don't know how. Please can any one help??

How can I make the tail lights shut off?

The front is lowered to the point where the tires are rubbing. the rear looks fine & inside the level screen it says im on level 3???

I've replaced the valve cover gaskets, cam tensioner gaskets, and half moon gaskets, but still have an oil leak on the driver side. After replaceing these gaskets, the oil leak has stopped on the passenger side, but still continues on the driver's side.
I have not yet replaced the rear cam cap/covers and am afraid to do so. I have read that these need to either be puntured and pryed out with a screwdriver or extracted with a special tool. I fear that I may cause unwanted damage and not be able to get them out if I punture them as others have done. What steps should I take next to eliminte this oil leak?

I know this is the secondary Air Injection System and I can't hear any leaks from a cracked vaccum hose and thought it could possibly be a relay switch but I can't locate the relays. Where would they be? Any other suggestions? I need to get the emissions done for new tags.

Hi, my audi 2003 allroad quattro 2.7L has staring problems.i drive to work and it will start perfectly fine. however, when leaving, it would take a pretty long time to start or i would need to repeatively turn the key to start the car. the voltmeter is normal, and so is the v-belt. engine oil level is a little low but i doubt it has anything to do with it. I do find that audis are not too reliable.

My Power door locks are sometimes not working. Both with the key and even using button inside the car. This happening to anyone else and is it an easy fix like a fuse or something? any help appreciated.

My friend got a 2003 Audi Allroad and recently replaced the air shock.

His symptom is the air shock light will suddenly show blinking while driving. The light has four levels. Usually he drove at 2nd level (from bottom to top). However, I experienced one time I saw the (L1 & L2 & L3) blinking together. And, the compressor is pumping. Sometime, he parked the car, he found it lower to touch the ground at next day. But, he did replace the air shock. Now, he is trying to put on L4 every time parking. Most scary is the compressor pumping while driving. It could lower down to the ground and get damaged.

Is anyone familiar with the situation or knowing how to fix?