Close

2002 Audi A6 Quattro Questions

Get answers to questions about your 2002 Audi A6 Quattro at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
61
questions

And how do you change it

I want to change the transmission

Happens every time you try to put in drive won't shift in drive but will shift every other gear

It is a simpler question. How many cats are there on the 2002 Audi A6, 3L

I have a 2002 quattro 3.0 and I have been trying to track down the source of my reoccurring P0300,301,302,303 misfires... I have tried all the usual suspects... Replaced plugs and coil packs, O2 sensor (even though there was no o2 fault code and now there IS P0140), patched an exhaust leak, replaced breather hoses (found them cracked and broken when I did the o2 sensor), found that the vacuum line was not connected to the fuel pressure regulator so I reconnected it (NO change) I can't pass emissions with my check engine light coming on every time the car warms up (the only reason it goes off is because I clear the code)... Where should I go from here? (with very limited resources)

Runs great except when idling it cuts out and shakes. Any ideas? Also have headlight issue. Headlights will not go down to low beams and high beams work good. Checked several things. Changed out headlights from used car and not sure if that's the reason or if need to try something else or any ideas what to check?

costing/light braking to a stop and the anti-lock brake fires several times. then all is well. this happens in the summer. how can i fix the issue. The ESP light comes on and dealer will not invest the time to find the issue, just sell a new car

if i try to idle at 1000 rpm it surges from 2000 to 500 rpm it has emission codes would exhaust leak or emission sensors cause this ?

What could it means no oil is leaking