Abnormal Noise or Vibration on Acceleration on Scion xD

Problem Description and Possible Solution

An abnormal noise or vibration on acceleration from rest or on gear shift may develop. Our technicians tell us a redesigned left side engine mount insulator is available to address this problem.

Problem Data
RepairPal Verified
Average mileage: 88,420 (15,000–182,450)
3 model years affected: 2008, 2009, 2011
20 people reported this problem
Get Your Car Fixed at a RepairPal Certified Shop.
We certify shops based on expertise, quality work, and verified customer reviews
Viewing 1 - 12 of 12 comments
abnormal noise and vibration on acceleration, also have rattle noise. Very annoying and as often as ive had it in no fix as of yet. Not happy with this one bit....
I HAVE THE SAME PROBLEM, WHEN ACCELERATE THE ENGINE START MAKING ABNORMAL NOISE AND VIBRATION.??
I WONDER WHAT CAUSE THAT?
Manual 5 speed will evidence a distinct higher pitch noise or whistle every time I accelerate. Independent of the clutch, and always stops the second I decelerate.

Local Toyota/Scion dealership's mechanic did not hear the sound. So, I asked to ride with one to see if it occurred while in the car together. Mac, the service rep. did ride with me, the noise was clearly there - subtle, but clearly there - and he did not hear it.

I plan on continued web research and a follow up visit to this or another dealer. It's real, and it's under warranty. I will not let this one go.
Very strong vibration while under throttle in 1st and 2nd, more than 1/4 to 1/3 throttle. 5 speed manual. 3rd gear, hardly an issue unless merging at WOT
low pitch noise the increases on acceleration especially when turning to the left
Noise that eventually became a rattle. Then I couldn't accelerate any more. Trying to get it fixed now.
abnormal whining noise in all gears and idle
Problem started around 75,000 but has just gotten worse to very bad noise and rattling now the dealer told me it's the alternator
Small whistle noise under slight acceleration, silent thereafter. Dealership says waterpump and belt. I will update next week following my apt.
Vibration after start up and moving between first and second on automatic transmission.
The bolt at the top of the motor mount insulator sheered off. I am having a very difficult time finding a replacement bolt. The diagrams online do not show this bolt. They do show the adjacent bolt that connects the stay to the engine, but that bolt is significantly smaller than the bolt at the top of the insulator. The insulator bolt takes a 17mm socket.
rapid clicking noise at mild to moderate acceleration,no fix,no money!
alot of heat emanating through firewall,cooking feet and legs.