» » »

Dodge Q&A

Ask Your Question

1994 Dodge Viper Question: The speedo and cooling fans stopped working after sitting.Someone help!

 

Question

themix1, Schertz, TX, December 31, 2011, 17:34
 Rookie

I had my car in storage about two months and drove it today. The speedo and cooling fans quit working as well as the shift lights...can you please help

2 Answers
Flag This
  • Answer #1

    PARTS GUY December 31, 2011, 18:54
    Profile_thumbnail
     Master

    Yes, take it to a professional repair shop and let them diagnose and repair it.

    Flag This
  • Reply

    themix1, January 01, 2012, 11:35
     Rookie

    Thanks for your highly knowledgeable response....smart axx

    Reply
    Flag This
  • Answer #2

    MATCO57 January 01, 2012, 13:10
     Technician

    Customer Concern: Cooling fan is inoperative.

    Tests/Procedures: 1. Unplug the Engine Coolant Temperature (ECT) sensor. The cooling fan should run.

    2. If not, check for voltage on the Gray wire at pin 30 of the cooling fan relay (not the hi/lo relay). The Gray wire should have B+.

    3. If OK, jumper the Gray wire to the Light Green/White wire. The fan should run.

    4. If it does, check the control wire from the fan relay to the Powertrain Control Module (PCM) pin 2 on the gray connector.
    Tech Tips: The low speed fan should run anytime the A/C is on or if engine temperature is at least 209 degrees Fahrenheit.

    Flag This
  • Reply

    themix1, January 01, 2012, 19:06
     Rookie

    Thanks for your help..I shot the fuse box with the car running all are powered...does this help? The temp gets to the last dash past 190 and no fans come on

    Reply
    Flag This