» »

Reviews for Mercury Mountaineer years:

  1. (8)
  2. (6)
  3. (2)
  4. (5)
  5. (0)
  6. (6)
  7. (18)
  8. (7)
  9. (2)
  10. (2)
  11. (0)
  12. (1)
  13. (0)
  14. (0)

Owners' Reviews

1997 Mercury Mountaineer Reviews and Owner Comments

 
1997 Mercury Mountaineer
8 Reviews
Write Your Review
Overall Score (8 reviews)
  • Body, Interior & Misc.
  • Engine
  • Brakes
  • Exhaust & Emissions
  • Drive Train
  • Heating & Air Conditioning
  • Electrical & Lights
  • Suspension & Steering
1997 Mercury Mountaineer Owner Reviews (8 reviews)
  • 1997 Mercury Mountaineer
    Visitor, Mountlake Terrace, WA, April 03, 2013 18:34
    We have had this vehicle for many years. Inherited it at 70k miles. we had 40 acres and it was the only vehicle that never got stuck. We used it to pull out the other rigs when the ground was to mushy, like a tractor and a big box truck and a f250 high boy. I dont know what they did to make the traction work so well but its absolutely amazing. has 197k miles now and still run great. It has always started, charged, heated, cooled, I would definately buy another one as I am impressed with every mile it works, oh towed our 23' cobalt regularly best thing to have at the boat launch!
    Flag This
  • 1997 Mercury Mountaineer
    Visitor, Cleveland, TN, January 18, 2012 23:21
    97 Mercury mountaineer, where do i began, worked great since purchased New until it hit around 1000k miles now at 200k, can't open rear doors from inside, door lock switch doesn't work, air conditioning only works on MaxAc, popping in front driver side when i turn hit a bump or stop too quickly, have replace thermostat twice in two years, has had alternaor rebuilt, changed harmonic balancer, serpentine belt every year, all three catalyst converters bad which causes terrible idling like dying down at a red light and plunging forward after releasing the brake, lights in dash are almost black now, no prop for hood, ball joint bad in both front wheels, and the list goes on.
    Flag This
  • 1997 Mercury Mountaineer
    Visitor, Pinellas Park, FL, September 01, 2011 12:04
    bought my used it has 148,000 miles everything works great i cant complain.put custom exhaust and supercharger in it .I have about 400 hp now.Had to put upper and lower control arm in it bt thats all i have had to do.
    Flag This
  • 1997 Mercury Mountaineer
    Visitor, Yonkers, NY, May 08, 2011 16:28
    I bought my Mountaineer in 2008 with only 54,000 miles. It now has 107,000. I have replaced the fuel pump,the power window,door switch, and head gasket, in addition to needing brakes.Today I discovered that the a/c compressor wasn't coming on. I now have to check if there is a leak. I have not had any front end,transmission, cooling, or exhaust problems.Half the mileage that I have put on this car have been highway miles. City or Highway, I average about 12-15 miles per gallon.Overall, I have been pleased with the performance of this car. Wanna buy it?
    Flag This
  • 1997 Mercury Mountaineer
    morningsun, Memphis, TN, June 05, 2010 10:21
     Rookie
    I bought my Mercury Mountaineer new in 1997. After 5 years, the antenna stopped working. The emergency brake never has worked. The only response from the dealership was, "It works, you have a V-8. Stop putting so much pressure on the accelerator". I do not pass inspection each year. I show the paperwork that the company tried to repair problem. I can't afford another car. Presently, it is in the shop, the sway bar appears to be the cause of the grinding, popping sound when I turn the steering wheel and / or apply the brakes. The bushing is broken. Also, the electrical system on the passenger side of the door doesn't work. I received a quote for $600.00 to repair the system. I manually lock the door. The cd system stopped working after six years. The check engine light repeatedly comes on after a repair. It has been on now 2 years. Oh well. How could I forget about the Lumbar feature. It stopped working during the 4th year. I rent a car for long distance driving. I do not plan to purchase another Mercury Mountaineer.
    Flag This
  • 1997 Mercury Mountaineer
    Visitor, North Las Vegas, NV, April 03, 2010 12:14
    I bought my 97 used with 97,000 miles.. ran great for the first 4 months then the engine light came on and with constant repairs stays on. EGR tube and or compoant seems to always be the problem. My cd player has stoped working, my back doors will not open from the inside, my inside cover around the skylight is falling, the ac only works good if going on the highway and the electric side mirrors are now manual. I just spent $1000 fixing things to pass smog 6 months ago and my engine light came back on. Now with more problems. Ideling to high, lunging forward from a stop to almost die out if I dont hurry up and press the gas. My front ball joints have been replaced only to crack again. I am tired of putting money in this vehical but since I am out of work its the only thing I have.
    Flag This
  • 1997 Mercury Mountaineer
    mtittle, Brookwood, AL, March 03, 2010 10:31
     Enthusiast
    Just purchased February 22, 2010 with 148k miles on chassis and supposedly less than 20k on rebuilt engine. Just had all spark plugs and wires replaced, and fuel system cleaned. Next will be brakes all around. Supposedly two O2 sensors need replacing. Supposed transfer case leaks. Power door lock on driver's side does not work. Seatbelt latch on front passenger side gets stuck, so I have new replacement part to have put on. Roof lining around sunroof in poor shape, going to add decor for temporary satisfaction. Hood has no prop up stick -where do I find that.. and hood latch needs adjustment to be able to fully latch down tight.. still a good car.. just in the works to be better.
    Flag This
  • 1997 Mercury Mountaineer
    CastAway, Winston Salem, NC, April 17, 2009 19:29
     Enthusiast
    Bought the truck used with 57,000 on it. It looks just like the one in the picture! Had the transmission rebuilt at 60,000 due to problems (used car dealer did under his warranty). Had to replace a cracked exhaust manifold. Battery acid dripped onto a vacuum line and caused major leak. Radiator sprang a leak and had to be replaced. Had to replace the front end suspension links at 190,000. Recently, the electric door lock on the driver's side stopped working. I use this vehicle to tow a boat and it is a real workhorse. My wife loves to drive it because of the higher view she gets of traffic. I would buy another one in a heartbeat!
    Flag This
Ask a Question