Close

Oldsmobile LSS Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
My car is misfiring and not getting enough oil and is blowing out major smoke when i turn it over and making a ticking sound. It stays started for bout a min then dies. What could cause this problem
The radio is non OEM and wierdly wired by former owner that is probably the cause?
Replaced water pump and freeze plug.Started fine. Sit for 2 mts put gas in and would turnover but not start. Was like it was out of gas. Would sputter some and back fire some but will not start. Can hear fuel injector kick in. Don't know if it has a relay for sure or not. In the past before water pump went out it was missing some.
The ac vents in the center are not blowing out how can I find the ac ducts
It smells like it's hot but the overflow is still full but I've had to add to the radiator.
It started by volume going up all the way when I turned it up a little bit an all the way down when Turing it down a little bit
My car will started then it will shut off sometimes it will start right back up after it shuts off or sometimes I will have to wait 20 minutes then it will start up. I checked the fuel pump and battery an alternator and all of that is good. So I need help to see what else it could be.
Where do I find out which one it is I have look on the body code and it doesn't say either
I was driving it, one of the belts came off, I've tried numerous times to put the belt back on but it is WAY to long. I have no idea how it was running, I can tell you there were problems with the way it ran, But the one belt that is still on it is going around the supercharge part which is NOT in line with the other pulleys, but it was running like that. Please help I'm a girl trying to work on a car because I CANT AFFORD WHAT THE SHOPS CHARGE TO FIX IT. PLEASE HELP!!!!
It always showed farenheit somehow it changed to celcius I dont think i hit anything and if i did i dont know what
Can't start car replaced starter 1year ago and same problem now so I took hammer to starter and it started drove home and will not start. Bench test ok but no start when reinstalled . Banged with hammer and it started again. Replaced starter enable relay and still not start. With key on engine will start when hot wired but security shut off engine after 5 seconds? David
Fog lights
I already tried the manuals, doesn't say. I looked behind the glove box and under the hood by the firewall in the relay panel.
Car starts up but stalls frequently. New battery was installed. Could the problem be electrical?
Once I put the car in drive it stays normal for 27 seconds then it flashes 60 for about 1 minute and 7 seconds. The AC never comes on.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.