» »

Reviews for Mitsubishi Diamante years:

  1. (2)
  2. (0)
  3. (0)
  4. (1)
  5. (0)
  6. (0)
  7. (2)
  8. (1)
  9. (0)
  10. (1)
  11. (0)
  12. (3)
  13. (0)

Owners' Reviews

2003 Mitsubishi Diamante Reviews and Owner Comments

 
2003 Mitsubishi Diamante
3 Reviews
Write Your Review
Overall Score (3 reviews)
  • Body, Interior & Misc.
  • Engine
  • Brakes
  • Exhaust & Emissions
  • Drive Train
  • Heating & Air Conditioning
  • Electrical & Lights
  • Suspension & Steering
2003 Mitsubishi Diamante Owner Reviews (3 reviews)
  • 2003 Mitsubishi Diamante
    Visitor, Steubenville, OH, March 20, 2013 20:29
    2003 Mitsubishi Diamante' LS -- Very nice This has been my favorite car that ive owned so far. The luxury aspect of it reeled me in. The heated leather seating smooth ride. The fact that the memory buttons on the driver door always adjusted to my comfortable seating position AS i was getting! yaaa THATS NICE
    Flag This
  • 2003 Mitsubishi Diamante
    niecyt, Sacramento, CA, January 20, 2013 12:19
     Rookie
    I bought the car with 20,000 miles on it and the abs light came on in the first storm. I didn't have the pump replaced, too pricey. I now have 108,000 miles on it, have always had it serviced, but the valve cover gaskets are leaking now. I have had some brake jobs done and things like that but I think they did a lousy job, they have always squealed since. I don't like how low the front end is, it scrapes over low bumps and such. The interior is perfect (leather) all the fancy upgrades work except the heater never works down on the floor, just in the middle. A/C is great, speakers are a bit blown but think it was done at a shop when I had body work done, it was a great system. I have put a LOT of stop and go miles on it going to work and that is part of the problem with brakes and such. Its been a good car but think its getting tired. Not as good as a Toyota or Honda for sure.
    Flag This
  • 2003 Mitsubishi Diamante
    jazziejae03diamante, Lubbock, TX, July 14, 2009 00:52
     Enthusiast
    I just purchased this car from a local dealer. It has 66k miles and so far everything seems to be okay. I did have the "service engine soon" light come on after a brisk breeze down a nicely paved rd (about 95 for less than a quarter mile). Culprit=O2 sensor. But the light has since gone off and not come back on. I will be tuning it up soon because it idles a little rough for my taste. slightly under 1k RPM Will report results.
    Flag This
Ask a Question