Close
Chevrolet Tahoe Problems

Rear Window Defogger Wire Terminal Broken Off of Window Glass on Chevrolet Tahoe

Problem Description and Possible Solution

The rear window defogger may stop working due to a wire terminal broken off of the rear glass. Our technicians tell us that terminal can be reattached using a special glue or silver solder.

(55 people reported this problem)

Chevrolet Tahoe Vehicles With This Problem

RepairPal Verified
Average mileage: 91,899 (2,400–288,000)
14 model years affected: 2000, 2001, 2002, 2003, more2004, 2005, 2006, 2007, 2008, 2009, 2010, 2011, 2014, 2016
Not Your Chevrolet Tahoe Problem?
Brake problem? Or maybe a faulty head gasket cylinder?
Learn About Your Car Problems
Search For a Specific Car Problem
Viewing 1-20 of 21 comments
Rear window defogger wire terminal broken off of window glass,need 2 know what kind of special glue 2 use and where 2 get it?
Rear window defogger wire terminal broken passenger side. Where do I get the special glue to repair it.
The rear window defogger wire terminal became detached from the solder location on the rear window. I have not had it repaired yet.
Rear window defogger wire broke off they tried to fix had to order new window. The window is new never open opened the windo hatch and it broke again on the new window two months after it was installed
If you cannot find the special terminal glue at your local auto parts store you can re-solder the connector using silver solder which has a lower melting point than regular rosin core solder.
Read defroster keeps detaching from window. I've had 2 replace window once and currently have to replace it again. I have had nothing but issues with this truck.
Reattached wire the first time at7318 miles. Replaced rear glass 3 times at 9285, 12000 and 12725. The wire came off again.
left defroster became completely detached (clean detach). I've opened the hatch window once, and this didn't happen then. It happened when I opened my trunk completely. Technician said the only way to fix it to replace the window completely. Not exactly what I wanted to do, since I've only had the vehicle 2.5 months, but he said it lasts longer than resoldering. We'll see. They've had my vehicle since noon 2/10/16 and I have yet to get it back... Not sure what takes so long.
Drove vehicle back to dealer for repair. They reattached the terminal. It never worked and now the terminal is hanging and broken. I cannot use the defogger.
I have the same issue but don't know what to do to fix it. Seems like the current suggestions arent working for others. Hoping someone finds a quick fix soon as winter is quickly coming.