No Electrical Power to Interior of Vehicle on GMC Envoy

Problem Description and Possible Solution

Electrical power may be lost to the interior of the vehicle due to a blown 125 amp fuse located at the under hood fuse box. This fuse can blow if jumper cables are connected incorrectly. Replacing the blown fuse will commonly correct this problem.

Problem Data
RepairPal Verified
Average mileage: 146,051 (74,202–360,000)
8 model years affected: 2002, 2003, 2004, 2005, more2006, 2007, 2008, 2009
25 people reported this problem
Get Your Car Fixed at a RepairPal Certified Shop.
We certify shops based on expertise, quality work, and verified customer reviews
Viewing 1 - 10 of 10 comments
After jump starting another vehicle the Envoy lost the power to the inside lights, radio and windows. We also heard a knocking in the radio area. We have the Envoy in the shop to correct the issue.
I can't get any power to roll down electr,ic windows,also no a/c,o
Or gauges rear doors wont open or tailgate
No interior power, seats, locks, radio, windows, heater
Thank you! I had this issue after my husband tried jumping his truck with my 2005 envoy! Everything on the interior- lights, windows, radio, a/c, etc didn't work. We replaced the 125 fuse and it all works again! Fuse cost us $7.49. Btw! We took it to a local shop before I saw this thread and the guy said it will be a very costly repair! Smh...
Had someone jump start my car, he said he thinks he connected them wrong and tried it again. It started, but now all interior lights, radio, power window and locks don't work.
No power on locks radio and interior lights .
Battery fails occasionally. Drivers window and locks don't work. All 3 other doors are fine. Radio doesn't stay on when key is turned off. Interior lights don't work when door is open, but will work by the switch.
Had to jump start. Now I have electrical problems. Not all of the instruments work.
Radio, power windows, locks and heater all don't work
many electrical issues where the vehicle just shuts down. changed the break light twice and both times stop working within the same day I had too many things done