Close
Buick LeSabre Problems

Improper HVAC Temperature and/or Air Delivery Due to Failed Mode Door Actuator on Buick LeSabre

Problem Description and Possible Solution

One or more heater & AC (HVAC) air delivery and/or temperature mode door actuator may fail. This can result in incorrect air delivery or temperature. If this occurs, fault code(s) stored in the HVAC control module should be available to assist with diagnoses.

(244 people reported this problem)

Buick LeSabre Vehicles With This Problem

RepairPal Verified
Average mileage: 127,939 (12,500–285,000)
15 model years affected: 1990, 1992, 1993, 1994, more1995, 1996, 1997, 1998, 1999, 2000, 2001, 2002, 2003, 2004, 2005
Not Your Buick LeSabre Problem?
Brake problem? Or maybe a faulty head gasket cylinder?
Learn About Your Car Problems
Search For a Specific Car Problem
Viewing 1-20 of 106 comments
The actuator behind the glove box is in working condition, however, when I turn on the heat, I can feel the warm/hot air blowing on my side(drivers) but it is freezing on the passenger side of the vehicle. What else could be the problem?
The battery died on the car and needed to be replaced. I jumped the Buick and when it started running again the air ac air flow would only come out of the defrost vents. The dash and floor vents aren't working now.
Hot air coming out all vents even when a/c is on and compressor is working.... Even when the whole system is off hot air still comes out all vents...
Air sometimes will not come out the vents, only the floor. Stop car, restart seems to help sometimes. Have replaced the vacuum manifold, but problem appears to be in actuator for the door which diverts air to vents or floor.
a/c will only work sometimes. blows through vents then will only blow on defrost/floor. very frustrating as it works mostly when it is cooler, not good for texas heat!!
When air conditioner is on, right side is blowing cool air, driver side is blowing warm air, freeon was added about 5 weeks before but mechanic did not feel there was a leak, it seemed to work okay for about 3 weeks
Not blowing cold air, ac is working, no, leaks, added freon and still seems like the heat is on
there seems to be a mouse in the vent system a odor comes from the air ducts how do i get to the fan?