1462calvin

Enthusiast
55 points
Recent Activity

Question Asked: 1985 pulsar nx wont start
December 01, 2009, 09:22 AM
i changed the ing.coil still wont start what else will have the car nor firing from the coil
Question Asked: oil pressure
November 30, 2009, 08:28 AM
What else would make you loose oil pressure replaced oil switch & oil pump twice still doing samething after oil breaks down
Question Asked: oil pump
October 16, 2009, 02:03 PM
would anyone know how to put a oil pump on and were is the oil pressure switch.
Question Asked: air in coolant system
September 09, 2009, 05:53 AM
do anyone know how to get the air out of the coolant system on the 3.9 & 3.0 ls
Question Asked: oil pressure & transmission
September 06, 2009, 11:16 AM
i have a new oil pump&oil sending unit i drive for about 15 min oil pressure drops between 5 to 10 psi what else need to be replaced? may transmisson runs fine fwd /rev but backing up one time transmission fluid came back up out the dip stick.
Question Asked: air in coolant system
September 04, 2009, 12:03 PM
do anyone know how to get the air out of the coolant system on the 3.9 & 3.0
Question Asked: coolant temp sensor
September 04, 2009, 07:08 AM
do anyone know the location of the coolant temp sensor its not by thermosat housing.it say heater core & head sensor.
Question Asked: runing hot
August 31, 2009, 05:35 AM
I filled it up with antifreeze saturday sunday night it was empty havent seen any A/f in driveway its not in the oil anyone know what going on.
Question Asked: theft light
August 20, 2009, 06:04 AM
Is there any way to reset the theft system light flashing like crazy? And would this have it not gettin fuel? I've replaced fuel pump,pressure regulator,& TPS I checked my fuses and relay also.
Question Asked: timming
August 18, 2009, 05:45 AM
replaceing the timmimg belt is that something someone with a little automotive knowledge should try if so do any have instructions.
Question Answered: engine service light
September 04, 2009, 10:55 AM
Go by a autozone an have them check it for free might just be a sensor.
Question Answered: tappin
August 31, 2009, 02:52 PM
Depending on the miles and if its a zero tolerance engine the belt could have slack in it you need to get checked cause if it break will driving you could bend a valve.
Question Answered: Check coolant level light
August 31, 2009, 02:47 PM
I've had this problem on several general motor! I replace the tank problem solve.
Question Answered: No heat
August 31, 2009, 02:42 PM
You could also replace the climate control switch.
Question Answered: transmission
August 20, 2009, 08:44 AM
is the rubber plug right under the transmission on the pan? if so yes its a drain plug try a transmission shop if they dont have one just replace the pan.
No activities found
No activities found
No activities found