Skippy1987

Rookie
0 points
Recent Activity

Question Asked: Check Engine light comes on, but goes off when I turn off the car and restart it
June 05, 2013, 01:25 PM
Problem occurs about 5 times a day.
Question Asked: Replaced both temperature sensors. Radiator fan stays on, won't shut off.
April 07, 2012, 04:03 PM
Replaced 2 temperature sensors. Radiator fan stays on - never turns off. Before changing sensors, fan only came on when A/C was turned on. Only shuts off when car is turned off.
Question Asked: Temperature gauge doesn't work since I changed the coolant temperature sensor.
February 01, 2012, 03:35 PM
Car would idle rough when cold. Changed PCV and MAP, then put in coolant temp sensor. Car runs fine, but temp gauge doesn't work now. Took off and turned 180* and sprayed with carb cleaner thinking it may have a coat of anti freeze on it. Do I need a bigger hammer? Thanks for the advice!
Question Asked: Engine barely idles when cold.
January 31, 2012, 12:34 PM
I changed the PCV and the MAP, but still no better. Runs fine when engine is warm.
Question Asked: 172,000 miles, misses at idle, but revs smooth once above 1800 rpm.
December 30, 2011, 03:49 PM
At idle, slight fluctuation and misses like plug is fouling, but runs smooth above 1800 rpm. Thanks
Question Asked: Sir, car runs fine until almost warmed up, then engine develops a stumble(miss).
December 29, 2011, 07:39 PM
Car has 140,000 miles with tuneup within last 10,000 miles. Thank You for your assistance.
No activities found
No activities found
No activities found
No activities found