sportsaddict1942

Enthusiast
62 points
Recent Activity

No activities found
Question Answered: radio
July 12, 2010, 08:43 AM
Yes you need the code and its 0368 on my 06'beetle.Go on line and look up your code to verify and follow instructions...In search box type VW radio codes...
Question Answered: Making a whirl or howl noise
July 12, 2010, 08:34 AM
You have a defective tire or front end issues...
Question Answered: odometer is on when key off
July 12, 2010, 08:31 AM
It will shut off after a few minutes when you get out and shut the door.If you look at it before you get back into the car you will see its off but once up open up the door it comes on without the key in the ignition.If it is staying on you have a door ajar or the hatchback is not closed all the way
Question Answered: Cooling System Problem
July 12, 2010, 08:25 AM
Your coolent light is blue when the engine is cold and off when the engine is hot.Your OK and as is the norm VW is trying to screw you ..Did they rip you off on the headlight repair?
Question Answered: heater switch
July 12, 2010, 08:15 AM
Its not the switch and its not a fuse,you have a speed control relay that needs replaced...Check on line for location such as Auto Zone or Napa
Question Answered: How many miles can I expect out of my Beetle?
July 12, 2010, 08:09 AM
A well maintained Beetle can last 200,000 or more but the downside is maintance..Timing belts,shocks,tires,alignments,etc can cost a lot.If your a beetle fan like myself you might be better off trading for a new one....Checkout the new CC way to cool and not many on the road...stands out like no other.
Question Answered: rear marker light installation
July 12, 2010, 07:58 AM
You can gain acess to these markers thru the side panels in the trunk area.once inside the panels you will a knob that you turn to the left.then turn the back of the bulb retainer to pull out the bulb to change.....
Question Answered: Car will not start
July 12, 2010, 07:51 AM
This sounds ugly...You may have low compression from a cracked cylinder heads.This cost a lot to repair...Good Luck with it.
Question Answered: A/C Fan not running
July 12, 2010, 07:47 AM
You have a loose connection at the fan or the fan needs replaced.Be sure to check for power comming to the fan by disconnecting the power source and checking with a tester.
Question Answered: electrical.controls not working
July 12, 2010, 07:43 AM
Have the speedo cable replaced...If computer operated check fuses or relays.
No activities found
No activities found
No activities found