Ms. Rita

Rookie
37 points
Recent Activity

Question Asked: My 2000 Ford Windstar failed the emissions test with (3) codes.
June 04, 2012, 03:36 PM
P0135-02 Heater sensor heater circuit malfunction bank 1 sensor 1, P01131-Manufacturer specific code, P0171-System too lean bank 1.
Question Asked: Why does my right brake light stay on sometimes and drain the battery?
December 26, 2011, 02:00 PM
I have to add brake fluid sometimes.
Question Asked: When I crank up the van I smell a fishy smell, the windows get foggy
October 11, 2011, 06:59 PM
And Antifreeze has leaked out the front driver side.
Question Asked: Why did 1998 ML320 fail emissions test twice?
October 04, 2010, 10:01 AM
On 8-21-10 my SUV failed the first emissions test. It gave codes P0100 Mass Air Flow Circuit Malf and P0400 Exhaust Gas Recirculation Flow Malf. On 9-13-10 Cleaned EGR valve and ports. On 9-24-10 replaced Mass Air Flow Sensor. 9-24-10 check engine light came back on, code P0400 EGR showed up again.
Question Asked: I'm hearing a noise coming from the driveshaft and front end of the truck.
August 02, 2010, 01:04 PM
It occurs everyday driving forward or backward.
No activities found
Problem Reported: Engine Performance Problems Due to Crankshaft Position Sensor Failure
September 15, 2010, 10:08 PM
<p>The <a class="ct_glossary tooltip" href="/crankshaft-position-sensor"><span class="ct_glossary tooltip">crankshaft position sensor</span></a> may fail. Symptoms of this are: The engine will crank&mdash;but not start&mdash;especially when the engine is warm. The car may start again if it is left to cool off, but it may run roughly or have poor performance.</p>
No activities found
Comment: Automatic Transmission Diagnosis
January 31, 2011, 08:29 AM
I have 74,000 miles on my 1998 Mercedes ML320. I have just put on a fuel pump and a crankshaft position sensor. Now the transmission is slipping.