» »

Reviews for Oldsmobile Alero years:

  1. (1)
  2. (11)
  3. (5)
  4. (1)
  5. (7)
  6. (3)

Owners' Reviews

2003 Oldsmobile Alero Reviews and Owner Comments

 
2003 Oldsmobile Alero
7 Reviews
Write Your Review
Overall Score (7 reviews)
  • Body, Interior & Misc.
  • Engine
  • Brakes
  • Exhaust & Emissions
  • Drive Train
  • Heating & Air Conditioning
  • Electrical & Lights
  • Suspension & Steering
2003 Oldsmobile Alero Owner Reviews (7 reviews)
  • 2003 Oldsmobile Alero
    alan53, Kirtland, NM, November 04, 2012 23:19
     Rookie
    spent a fortune on this 2003 alero and its broke down again. start the car and all the gauges go nuts. then the overheated light comes on and then the battery is sucked til it dies. this is a new battery. once it sets a few minutes the battery builds enough to start again but same results. And no it isnt overheated you can hold the radiator hoses and lay your hand on the radiator and its still cold. and the fluid is still cold.
    Flag This
  • 2003 Oldsmobile Alero
    uva, Dallas, TX, March 21, 2012 21:03
     Rookie
    SECURITY IGNITION PROBLEM!! (NO 'FULLIN') My blinking security light comes on and the car will not start. I then turn the IGNITION KEY to the right(1/2 way) and wait 10 TO 13 MINUTES UNTILL THE LIGHT STOPS BLINKING AND GOES OFF. THEN THE CAR STARTS RIGHT UP. HOWEVER, 2 to 3 WEEKS GO BY AND THE SAME THING HAPPENS, THIS HAS BEEN GOING ON FOR a little over two years. **TWO YEARS AGO IT HAPPENED TO ME WHILE driving through the town of 'EASTLAND' I was stopped at a local conveinient store. *IT WAS 20 DEGREES OUTSIDE. I Tried the key thing 4 or 5 times (as mentioned above), by then the battery was dead... A TOW TRUCK GUY came up to me and told me about a DEALERSHIP AND TOWED MY CAR THERE. THEY THEN CHECKED IT OUT AND TOLD ME THEY NEEDED TO PUT IN A NEW BATTERY (THEY WOULDN,T LET ME PUT A NEW ONE IN OF MY OWN) and charged $229.00 for a battery, $75.00 to SCREEW it on. (Oh ,did I mention they wanted me to wait while they ordered the part which would take 3 days to arrive. The owner of the dealership (brother was the mayor) suggested I stay in one of the towns hotels .(My father, several hours away, drove into town and told them he would go pic up the part and drop it back off at the 'FULLIN' DEALERSHIP, two hours away. and did so.) I felt that I was in one of those movies, "A STRANGER COMES TO TOWN!" "NO FULLIN!!" THEY THEN PUT ON A NEW FUEL PUMP $670,00. THE BILL TOTALING $1009.00.. Then handed me the keys and said, "ITS WORKING NOW. We even made you a new set of keys and "PROGRAMMED IT" for you!" (The same thing that I have been doing all along untill this day.) Two months after that repair, the light appears again. I called them on it and they said ,"We'll fix it again for an additional 500.00!" ... ~p.s. since then I've found that when the security light comes on, it blocks off connections to fuel pump( an ant theft thing.) untill reset by turning key 1/2 way FOR 10-12 MIN.. ~~~How can one make this problem right?
    Flag This
  • 2003 Oldsmobile Alero
    Visitor, Des Moines, IA, August 08, 2011 00:13
    i am having trouble now i went on a trip to denison ia and on my way there i noticed my rpm starfted moving between 3000 and 4000 like it was jumping well then on my way back it like started slipping and now its everytime i drive it it will go for like ten mins then start messing up then i will shut off the car for about a minute or 2 and works just fine what could that be caused by
    Flag This
  • 2003 Oldsmobile Alero
    Visitor, New Prague, MN, November 14, 2010 06:14
    Great Car looks good, I have taken care of it. It has 146K the problem I can not find a fix for is, I do not have tail lights, dash lights, or 4 way flashers. It blowing the 15AMP fuse in the fuse box by the fire wall in the engine compartment. I have tried taking out all of the tail light lamps, taking the dash panel out and unpluging it, unplugged the 4 way flasher switcth, still can't figure it out. If you have any idea's let me know. Alero
    Flag This
  • 2003 Oldsmobile Alero
    danielharrison, High Point, NC, October 31, 2010 14:12
     Enthusiast
    engine not work
    Flag This
  • 2003 Oldsmobile Alero
    Visitor, Copperas Cove, TX, July 21, 2010 10:26
    I am an owner of a 2003 alero. I bought the car at 116,000 miles and it looks great. Even the mechanics say it still looks good. However, 2 days ago the car stopped while I was driving it. Nothing was wrong with it. there is no car note I pay so coming off of $440 to get the fuel pump replaced is no biggie. The car is great overall. I really do love it.
    Flag This
  • 2003 Oldsmobile Alero
    tincups, Minneapolis, MN, February 19, 2009 11:55
     Technician
    This has been an awesome car!
    Flag This
Ask a Question