Close

mikeyb4

Enthusiast 01be16a5a93688912f14755221fb15211b518d9a788cf01b455e03cc1bd585acEnthusiast
50 points
Recent Activity

Question Asked: dodge 3500 transmission.
August 23, 2017, 04:34 PM
Just wondering anyone else has run into this. This is my daughter inlaws truck. Bought it new in texas. 2010 dodge cummins diesel 4x4 dualy. Trany went bad. Guys at trany shop can't figure out why number on it don't match vin number. comes up 2008 and 9. I said dodge must used that trany in more than 1 year. Number on rear end comes up its a 5500.
Question Asked: white smoke coming off exhaust.
August 23, 2017, 04:22 PM
pretty sure not blowed head gasket. And doesnt do it all the time. Trany fluid driping out weep hole.
Question Asked: head lights don't work
July 19, 2017, 03:09 PM
read online needs new computer.
Question Asked: vibrates in right front at 75 mph. tread wearing uneven. stops past 75.
July 19, 2017, 03:08 PM
this is a diesel dully. 4 door. pulls to the right. replaced one bad ball joint two years ago. was allright for a while. but they used the cheapest ball joint from auto zone. has all ways pulled to the right sense buying new.
Question Asked: brake lights staying on.
April 13, 2015, 09:31 AM
brake lights quit working. got a new switch at the dealer. work now but will stay on. either tap brake or leave foot under brake pedal. notice when shut off. if I pump brake couple times it gets tighter. only 35000 miles and no leaks. but wondering if master cylinder getting weak and not holding pedal back. to keep switch turned off. or could it be booster.
Question Asked: Trans slipping
April 22, 2013, 06:55 PM
I have changed fluid and filter and added lucas trany additive and cured this problem before! But is their a problem with these trans I don't know about?
Question Asked: How hard is it to change valve stem seals on this? With the head on!
April 19, 2013, 11:38 AM
It has lots of blue smoke! Plus this really puzzled me! Ran a compression check. While cranking the needle in gauge went up but wouldn't stay. I can't believe all the cylinders are 0 it runs to good!
Question Asked: Had a bad stumble at idle and accelerating!
April 11, 2013, 07:00 PM
Had codes 300 & 307.changed plugs,cap,rotor,coil.wires are ac delco and only year old. No help. Then found out it had bad injector. Had the spider type. so put in the new mfi injector. This helped a bunch. But still has just a very little stumble at idle and giving it gas. 161000 miles.I think its just old and things worn out!
Question Asked: Has a stumble at idle and getting on the gas! codes po 300 & 307.
March 27, 2013, 05:46 PM
Changed plugs cap & rotor.Number 7 plug all black and foil looking.Still has stumble and codes 300 & 307 came wright back. notice orange fire not blue or white. Changed coil.Same thing no change.The owner called a another shop.And he said intake pressure valve or burn't valve. Witch I was getting ready to do compression check.The new plug in number 7 was still white. And got 120 psi. All the rest of the plugs was showing signs of firing and 160 to 180 psi. I'm thinking burn't valve. Also smell gas while its running and lots of water out tail pipe and from muffler.Maybe cracked head or gasket
Question Answered: my 92 dakota rolls over but no spark, no power to fuel pump, coil or asd relay.
October 27, 2011, 03:22 PM
i got same thing. the cranshaft postion sensor was bad.changed it still no go.
Question Answered: my tahoe
September 17, 2011, 01:00 PM
a worn out front hub will do that. maybe both
No activities found
No activities found
No activities found