35 points
Recent Activity

May 12, 2011, 07:50 PM
Hi Johnny, I went out last night, took out all of the bulbs as you stated and went through the process. There were sockets that I cleaned and I did check all of the by one! Right now the flashers work and so do the hazards. Thanks for taking the time to help with this. PROBLEM..... We took the car out tonight and the turn signals worked fine going to town and running a few errands. Just when I remarked how nice it was to have them and not to have to worry..bam...they quit working!!! Grrrrr. We had changed out one of the connector units on the front so I am going to double check the wiring on that to be sure the wires are all secure. Beyond that I am at a loss. Any more ideas?? Thanks again..Rennae
Question Asked: The Fuse For The Hazard Lights Is Blowing
May 08, 2011, 07:00 AM
Taking your advice I went out and double checked the fuses. Sure enough the fuse for the hazard lights was bad. I put in another but noticed a spark and the light came on for a split second then the fuse blew again. I went inside the car to see that I had left the hazard switch in the on position. I turned it off took a small piece of sand paper, cleand the corrosion and then replaced the fuse again. This time when I started the car and flipped on the turn signal it popped on but only for a couple of clicks and then quit. The fuse was blown again! I am going to check the bulbs but let me know if you have any other suggestions. Thanks so much!! R
Question Asked: New Battery
May 05, 2011, 10:48 AM
We changed the battery out for a new one. That is when we noticed that the cruise control no longer worked. Also, we noticed that the turn signals and hazard lights do not work. I checked all of the fuses but they are okay.
No activities found
No activities found
No activities found
No activities found