greenbeast007

Rookie
0 points
Recent Activity

Question Asked: electric,fuse ,or what
May 01, 2014, 12:50 PM
i replaced the ignition switch and was driving fine (not fully reassembled), even turned off and restarted. now get no power from ign. switch at all. (have clock, dome light n hazards). have already swapped out the switch n still nothing.
Question Asked: headlights dont work
January 23, 2014, 07:54 PM
went to turn headlights on same as normal but they flicked on then immediately off. tried off n on,. parked shut down n start again but still nothing..rest of my lights n flashers are fine. checked fuses n changed bulbs. no obvious loose wires
Question Asked: crankshaft wobble
December 27, 2013, 02:08 AM
I notice my main drivebelt pulley/crankshaft pulley was wiggling loose after a day 4x4. got home checked. lost all oil. found shredded seal thru hole in between timing belt cover and oil pump. Q#1 timing belt cover need to be sealed? Q#2 how to check balancer and crank w/o full engine overhaul? how check oil pump is not done and what else should I check etc. HELP PLEASE
Question Asked: exhaust leak
December 25, 2013, 03:44 PM
I have real bad leak at cat to pipe connection and huge crack down the muffler. could this be why have no torque when accelerating. do I need fix this before emissions
Question Asked: 92 p.f. has no go
December 23, 2013, 02:48 PM
truck runs descent but when accelerating rpm goes up but not speed. also it hesitates befoe reacting to the pedal
No activities found
No activities found
No activities found
No activities found