37 points
Recent Activity

Question Asked: back up lamps quit working changed bulbs same condition help
August 14, 2014, 04:19 PM
brake and turn signal lamps still work is problem in the bulb sockets or a possible broken ground wire. thanks for any help
Question Asked: My Service Engine Soon will come on.
June 27, 2014, 08:47 AM
When I check the system with a scanner at my local mechanic the code that appears is PO420. This car has a 3.1 v6 with automatic transmission. If anyone has encountered the same problem please e-mail any suggestions to correct the problem. Thank you and may you have a Blessed Day.
Question Asked: The AC heater system (hvac)switches to defrost when engine accelerates.
June 20, 2014, 07:19 PM
this problem occurs all the time,the system switches from normal to defrost and back to normal when the fuel petal is released and engine is not being accelerated. I replaced two check valves in vacuum system but still have same problem. Any help will be appreciated. Thank you.
No activities found
Problem Reported: HVAC Air Flow Switching to Defrost When Accelerating
September 15, 2010, 10:05 PM
<p>The <a id="ce_8277" class="ct_null tooltip" title="Heating and Air Conditioning" href="/heating-ac">AC/heater</a> (HVAC) system may unexpectedly switch to the defrost mode when accelerating. This system is operated by engine vacuum and should be inspected for any vacuum leaks if this problem develops.&nbsp; There is also a revised vacuum check valve available to address this concern.</p>
No activities found
No activities found