Close

2002 Toyota Echo Questions

Get answers to questions about your 2002 Toyota Echo at RepairPal. Find solutions, diagnose problems and get back on the road.

Refine by vehicle
×
Choose your vehicle
No car image 94a1663db56199c5353592009e34aaa51078a2469bed068bb8d6f0ba43accf97
Get a Repair Estimate
Guaranteed by certified locations nationwide. Learn more
RepairPal estimates are guaranteed at over 1,700 quality certified locations nationwide. Learn more
38
questions

car has new compressor, drier, expansion valve and cabin fan. Renew cabin fan because it nwould not run new fan will not run to.

on after i ve been driving for awhile

How much should it cost to replace an oil pump for my 2002 Echo? Most places estimate about $600 but the dealer and another place estimate about $1100. Why such a discrepancy in pricing?

new mass air idle control selinoid

heated cat not supported catalyst not ready evap system not ready egr not supported air system not supported air conditioner not supported

My air is not blowing cold air and I found a plug under the dash not connected to anything. I need to know where to plug it in. the wires are purple and pink

the man that put me a new one in didn't know how so another man came over and did it, if its not in there right will that show evap valve?

There is low air coming out of the vents.

Would also like to know if I can add a concentrated gas treatment for carburetors and injectors

It started when I slowed for construction and when I went to accelerate I could here this occasional knock. As i accelerated it increased so I pulled over and tried to find the problem. When I began to drive again I didn't here it.

My Echo engine has been very quiet since I got it, but about a month ago very occasionally it would sound like an old dump truck or tractor for just a second or two and then the sound would disappear. I thought I was hearing things at first or actually hearing a vehicle next to me. Then the sound lasted longer and longer. Now I hear the sound about 10 -20 % of the time the car is runnning, mostly when we are idleing at a light or just starting to accelerate. Any ideas what it might be. I'm taking it to a mechanic this week and I want to have an idea what to expect. JD

It feels like some kind of cable snapped. I'm afraid to take it to the dealer because they will find all kinds of things wrong with it. It has 66,000 miles on it.

several months ago, a service light came on. it is on the right side and is yellow. Also, the icon looks like a manifold(?) or the place where one would put oil. I checked fluids, was low on coolant, filled it. I disconnected the battery but a few days later the light came on again. Also, i believe it happened around the time the odometer turned to 60,000 miles (is this why?)

I suspect I got dirty fuel and my check engine light came on I want to replace the fuel filter but i can't seem to find it.

I cant find my cd player