Close

2003 Saturn Vue Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
159
questions
As soon as I start it up it sounds like vaccum cleaner running in the back seat ..It stay running on same speed through stopping or driving along..If I turn the fan off it just keeps running.
My Saturn vue 2003 some times won't start also sometimes shots off while I'm driving then back on suddenly, we replace fuel pump and filter already, still doing the same thing
where can I get a new solenoid for this cvt transmission?
The back bumper looks splattered with spots that will not wipe off it looks almost discolored
How long have you had this problem? Just noticed it today
It seems to be loose. If the headlights don't come on when I turn them on, if I push in on the end of the lever they'll come on. How do i change it out?
driving at highway speeds front end kinda hops when brakes applied. not so bad if i pump the brakes first
I took a motor out of 2004 saturn vue 2.2l with automatic and put just the motor in the 2003 vue with manual trans .The 2003 motor wiring would not match up, so i had to take the 2004 motor wiring harness and put in 2003 now the motor service lights stay on and motor has reduce power,speedo not working also! Could it be the Wiring harness (wires go to different pins in a socket from automatic and Manual Trans) or BCM??
Now are being told, as the initial coolant leak and into the oil reservoir/ground with visible antifreeze loss from radiator were never resolved from initial diagnosis and repair of replaced head gasket & $2,200.00 later on 12/17/2016. The car w/ 112 k, 2nd owner and all maintenance done on car. Several calls were made to service station, as well as vehicle being taken back twice & only 300 miles(limited driving-nursing my vehicle and countless contact to manager at service center where services were supposedly rendered) on car since 12/17/2016. Now are told, my car rejected the head gasket due to what is believed is a cracked engine block. Being inform of this, when it were noticed where car were parked routinely, had new area leaking under the car. Shortly after this discovery, I assessed engine by popping hood and saw oil/coolant spots all throughout engine, including the valve cover gasket seals/seem along engine. Now, same company says they will replace the head gasket under warranty but it is recommended I replace the engine out too at my cost. Someone assist- please help ! This car is going to be the death of me, as I am so frustrated financially and with the poor services had by a local to me shop, that it is felt due to negligence has killed my car. My engine always running strong and never ran the same after said mentioned initial repair. Please note, this known name shop changed it's name under another umbrella name and is no longer BB accredited.
Ive had it a few years and has been great with no problems. A few weeks ago, on the interstate, it began making a buzzing/gringing noise but still ran. A week later, after driving 20min or so it began squealing loud. After that, it would die at a stop but only once the temp got up to normal. It died at a light, i started it, began to go and completely died and now it wont turn over, start, or anything. Battery is new, oil was good and it started all of a sudden.
Junk or fix-keep ? Limited funds, only transportation source. Engine strong-Please advise.
went to get my NYS inspection renewal and got a failed result for emissions but the only code I got was "KOER" and in researching further it was key in off position while engine was running. I did find out there was a recall on it and wondering after I get that fixed would that take care of the failed inspection if that is the only code that comes up
can i get the switch replaced at no cost?
In the Inspection summary, I got:
Inspection result: FAIL
Safety: PASS
Emission: FAIL
Emission Results
KOER FAIL;
There were no specific diagnostic codes. The mechanic that performed this test didn't know what it meant either and told me to go to someone that can explain what this means. a few months back i replaced drive shaft and valve covers. i did have a diagnostic code Exhaust Valve Control Solenoid Circuit High (Bank 1) high purge flow and the purge valve solenoid was replaced.
mostly freeway, short hi-way, total approx. 15 miles. reversed about 20 ft. wouldn't start. everything worked, wouldn't start. open hood engine hot but gauges all normal. suspected starter, 7 hrs. later engine starts.
Engine light has been on before and after car went into dealers for a crack intake manifold. Dealer managed to get a used one with no guarantees. Dealer said problem with valve cover leak is just a mater of time. This leak effects the spark plugs also. What can be done?
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.