Close

Toyota Matrix Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
167
questions
Radio seems to work fine.
If I go over 70mph.
It happens when I step on the brake all the way.
I just had the engine replaced. Now I have had the code twice for P0907.
i have a fairly new Battery, radio,power windows work , but i turn the key to start the car and nothing happens ,Does not even turn the engine over.
I just bought the car used so I don't know yet how often it occurs, but I noticed it after it had been driven a long distance in the rain. The edges are dry, only the middle is wet.
Brakes have been grinding for a little while now and I'm worried about the rotors being damaged from it. How could I at least get an idea of what condition they're in?
I was driving in the palmetto highway I passed under something since that time the wheel want to stay to the left side and when I accelerate the car shake
Toyota has a service bulletin VEHICLE SPEED CONTROL:ACCELERATOR PEDAL.
Does this have anything to do with my problem and with the dealer fix it at no charge?
Had a mechanic repair valve gasket for an oil leak. What should have taken him one day, took him three days. Ten minutes after driving away my check engine came on & the chain started making noise in my engine & vibrating my whole car. It sort of feels like a misfire but it's not (I had another matrix that misfired @ one point). I also stalled out twice while turning on & when I put it in drive another time. I'm trying to avoid having someone disassemble my entire engine to figure out whether or not he dropped something down my engine or something is very wrong. I had my friend's dad look @ it & he rewired the thing & put new engine coils, fuses, & a couple of sensors in it. My check engine light is still on after all of that. The guy who repaired the valve gasket says I hustled him (I asked for the money back because my engine was never acting like that before I brought it to him & he went budge on telling me what happened). Is this a common problem? Does anyone have any idea on what it could be? I need the car for school & I'm also a full time nanny who needs a car to drive the kid I nanny for. Any response would be appreciated! Thank you!
I have tried the spare key, with no success. There is no response.
I do not think the battery is dead, since the car started up fine a couple of hours earlier. How do I override/disable the security system, if it's keeping me from starting the car?
has anyone had this issue? car only has approx 67000 miles on it.
the repair shop quoted me $795 to replace both axels and boots and they are planning to use after market parts. is this price fair and are after market parts safe to use? i'm planning to keep the car as long as possible, will the axels and boots need to be replaced again in another 67,000 miles? thanks for any input.
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.