Close

Pontiac Firebird Questions

Get answers to your auto repair and car questions. Ask a mechanic for help and get back on the road.

Find questions for your car.
350
questions
Checked the fans with fuse wire both ran connected to the battery. Replaced temputure sensor and 3 relays. Temputure is at 245 degrees not turning on please help what did I forget?
have oil in my radiator , but the engine oil is clean. does not over heat, engine in not missing, runs fine but need to put water in the radiator every day. no visible water leaks. no smoke out the exhaust. anyone have a clue? has automatic trans and Radiator IS equipped with an internal transmission fluid cooler
My lights are working...my power windows are working and radio...upon trying to start car...it will not make a sound! What could be wrong?
My fuel pump is good and a pressure of 42 and has a brand new fuel filter. Could it be that it needs to be tuned up, the distributor cap, or the fuel injectors?
Every other day I have to wait for security light to go out to start car what do I do
can i use a leak fix additive for a quick fix?
Slow down to turn quits sits for a few minutes starts back
Engine idles high then starts to missfire after it warms and the idle never decreases. Engine dies and will not restart until cooled. Fuel pump, relay and filter are new! Distributor, Ignition control module, coil, MAP sensor,and air filter have less than 1000 miles on them...
The car startso and then cuts out and dies won't stay running at all and every once in a while it will start and run
i was trying to start car with battery charger and now i can get any electric power .did i blow a fuse
My passenger light goes down when I turn the lights on.
Ok, so i have a V6 3.4 L engine and i have just replaced my fuel injectors, map sensor, vacuum lines, fuel tank and pump, both O2 sensors, and the air control valve. it will start up fine, it revs up to about 1200 then idles at 900~, and will idle for a few minutes(5-10 roughly, haven't counted), and i can press the gas down fine and it'll rev up, but as soon as i put it in gear (its a manual 5 speed) it dies, as if i turned it off(DOES NOT make any coughing noise like there's no fuel)... then after that when i turn it on it will turn on and idle for maybe 2 seconds, then dies. Please help!
OK, i recently bought a 1993 firebird V6 manual, it had sat for about 9 years. got it up and running, was running perfect. then one day about 2 months after i got it running and been driving it almost everyday. it wouldn't start, so i jumped it and it drove home fine. Then i drove it up to VA, (130ish miles away), but while driving it back, it started to kick, and the check engine light flashed every time it would kick, but when i took it out of gear it was fine. so i got it back home, thought it was the alternator, so i took it apart, but it looked fine so i took it to oriellys, they checked it and said it was fine, battery is new. so i thinking it may be a wire at the firewall. Please help! getting kind of frustrated!
Okay so I have done alot or research on this. So I went ahead I got a new lock cylinder and plug it in where the original one was plugged in. I have the new lock cylinder under the dash just plugged in. And my security light is still on and car will not start. I also , tried the resistor to bypass the Vats system
I disconnected the original ignition Titus in the steering column and plugged in my new lock with key van security light is still on please help
Get an estimate and never overpay again
RepairPal guarantees your repair will be done right.